Home > Community > Forums > PCB Design > Problem with smoothing split plane

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Problem with smoothing split plane 

Last post Tue, Jan 22 2008 2:00 PM by archive. 5 replies.
Started by archive 22 Jan 2008 02:00 PM. Topic has 5 replies and 1741 views
Page 1 of 1 (6 items)
Sort Posts:
  • Tue, Jan 22 2008 2:00 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    Problem with smoothing split plane Reply

    Hi,

    I have the following situation: see attachment. The split plane is ground and a dynamic shape. The status dialog says, that the planes are already smoothed. I think the problem could be deleted islands which results in not correctly smoothing the shape. What can I do now? I just want to click somewhere "Refresh" and everything is OK...


    Originally posted in cdnusers.org by jehle
    • Post Points: 0
  • Tue, Jan 22 2008 2:19 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    RE: Problem with smoothing split plane Reply

    Hi,

    I forgot: Allegro PCB Design 16.0

    regards
    Guenther Jehle


    Originally posted in cdnusers.org by jehle
    • Post Points: 0
  • Tue, Jan 22 2008 2:42 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    RE: Problem with smoothing split plane Reply

    Looks like there is some static voids in the shape that will never be smoothed. I updated the attached image to indicate the voids that I believe are static and not dynamic. The only way to correct these is to delete the voids in question and have the void be regenerated dynamically. Here are the steps: 1. Select the outside edge for filled area of the shape for modification using Shape > Select Shape or Void 2. Select menu Shape > Manual Void > Delete the select the edge of the voids that appear to be out of date or use the right mouse button option "Delete all Voids" if you do not want any manual voids. The steps above will remove the manual voids so dynamic voids can be regenerated. Hope this helps, Mike Catrambone UTStarcom, Inc.


    Originally posted in cdnusers.org by mcatramb91
    • Post Points: 0
  • Wed, Jan 23 2008 2:28 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    RE: Problem with smoothing split plane Reply

    Thank you. This is the solution for my problem. The procedure with deleting islands and after a change the needed deleting void seems to be not very intelligent. Is it possible to create a dynamic shape wich doesn't generate this islands (automatic)?


    Originally posted in cdnusers.org by jehle
    • Post Points: 0
  • Wed, Jan 23 2008 10:27 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    RE: Problem with smoothing split plane Reply

    You also might try a couple things:

    1) Turn on the Etch Boundry layers, and see if you can find these void areas and delete them
    2) Find a coordinate that would allow you to move this shape completely off the board; move it, and regenerate the shapes; then move it back on the board and regen.

    Either might also help you out. (I know, I've done it on some 11" round board I've had to ECO changes into, and they had GND fill on all layers in the open areas.

    Good day.
    Mitch


    Originally posted in cdnusers.org by cadpro2k
    • Post Points: 0
  • Thu, Jan 24 2008 8:14 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    RE: Problem with smoothing split plane Reply

    jehle,

    Sorry for my delayed response. I was traveling yesterday.
    To respond to your last question "Is it possible to create a dynamic shape which doesn't generate these islands (automatic)?"
    The short answer is Yes but let me explain:

    You can modify the "Minimum aperture for artwork fill" and "Suppress shape less than" values under the Void Control Tab of the Shape parameters that will limit the amount of islands that are formed in a dynamic shape You can modify the Shape Parameters on an individual shape (select shape and select Parameters from the Right Mouse Button) or make the change for the entire design for all shapes (Shapes > Global Dynamic Parameters)

    I have to admit that I have never seen "Delete Islands" leave manual voids behind that caused the issue you are seeing. I have seen manual voids created when using "Merge Shapes" when separate shape boundaries form a void after merging.

    Hope this helps,
    Mike Catrambone
    UTStarcom, Inc.


    Originally posted in cdnusers.org by mcatramb91
    • Post Points: 0
Page 1 of 1 (6 items)
Sort Posts:
Started by archive at 22 Jan 2008 02:00 PM. Topic has 5 replies.