Home > Community > Forums > PCB Design > 16.0 migration - Application Mode graphics irritating

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 16.0 migration - Application Mode graphics irritating 

Last post Wed, Sep 26 2007 2:26 PM by archive. 12 replies.
Started by archive 26 Sep 2007 02:26 PM. Topic has 12 replies and 1587 views
Page 1 of 1 (13 items)
Sort Posts:
  • Wed, Sep 26 2007 2:26 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    16.0 migration - Application Mode graphics irritating Reply

    I would like to know how to turn off the application mode hilightling in 16.0. I find it very distracting and irritating to have things highlight when the cursor just moves across them. Anyone else with me on this? I can turn it off temporarily in the menu or with appsmodeoff but it comes back on the next command. This is bugging me enough to go back to 15.7 if there is no way to turn it off. I have looked through the setup env options and did not see anything there.


    Originally posted in cdnusers.org by dlocke
    • Post Points: 0
  • Wed, Sep 26 2007 2:33 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: 16.0 migration - Application Mode graphics irritating Reply

    I am not sure if this answers your question or not but you can set the Application mode to None to disable the new pre-selection behavior. Under the Setup Menu select Application Modes --> None

    Hope this helps,
    Mike Catrambone
    UTStarcom, Inc.


    Originally posted in cdnusers.org by mcatramb91
    • Post Points: 0
  • Wed, Sep 26 2007 2:41 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: 16.0 migration - Application Mode graphics irritating Reply

    Mike, I have tried that and it works ok until the next command is executed. I have not downloaded any hotfixes yet as this looks like a bug. I am curious if you are seeing the same behavior with turning it off only lasting until the next add connect etc. Please let me know. Thanks,


    Originally posted in cdnusers.org by dlocke
    • Post Points: 0
  • Wed, Sep 26 2007 3:06 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: 16.0 migration - Application Mode graphics irritating Reply

    No. I am not seeing that behavior. I can set the Application Modes to None and it seems to stick. If I open a new design in the same session it reverts back to General Edit Application mode but as long as I am in the same design the setting sticks.
    I did download the Hotfix that was available earlier in the month so maybe the issue you are seeing was corrected.

    Mike


    Originally posted in cdnusers.org by mcatramb91
    • Post Points: 0
  • Wed, Sep 26 2007 3:23 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: 16.0 migration - Application Mode graphics irritating Reply

    That is good news to me that the hotfix will correct that behavior. Thanks a lot for the information Mike. Dal


    Originally posted in cdnusers.org by dlocke
    • Post Points: 0
  • Wed, Sep 26 2007 9:48 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: 16.0 migration - Application Mode graphics irritating Reply

    Try the following:

    Setup + User Preference Editor + Z-early_adopter
    Make "datatips" deactivate it.

    satya


    Originally posted in cdnusers.org by satya1234
    • Post Points: 0
  • Thu, Sep 27 2007 8:50 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: 16.0 migration - Application Mode graphics irritating Reply

    BTW, That's how you disable data tips in 15.7

    In 16.0 you disable data-tips from, Setup => User Preferences => Preselection .


    Randy


    Originally posted in cdnusers.org by rb
    • Post Points: 0
  • Thu, Sep 27 2007 9:25 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: 16.0 migration - Application Mode graphics irritating Reply

    Good tip on the way to turn off the data-tips via User Preferences.

    I believe that the original question was to turn off the application mode highlighting and just turning off the data tips will not stop the element highlighting when you mouse over it.

    Mike


    Originally posted in cdnusers.org by mcatramb91
    • Post Points: 0
  • Thu, Sep 27 2007 10:16 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: 16.0 migration - Application Mode graphics irritating Reply

    *Here is a solution to keep the cursor hover highlight flashing off permanently in rev 16.0. Add this line to your env file: set script_startup = start Make a file called allegro_start.scr in your script path with contents: echo "Running allegro_start script to turn off application mode hover highlighting . . ." noappmode --Works like a charm. More info: (Notice it prepends "allegro_" to the script name you have in your scriptpath so be aware of this when naming the script!) script_startup : Script name used on startup. We will prepend the program name to the name provided (_), and lookup the filename using SCRIPTPATH. No warning is issued if script cannot be found. More flexibility can obtained by using the "-s <script>" option when starting the program. Example: "script_startup = foo" results in our looking for allegro_foo.scr when starting allegro and pad_designer_foo.scr with pad_designer.


    Originally posted in cdnusers.org by dlocke
    • Post Points: 0
  • Fri, Sep 28 2007 6:48 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: 16.0 migration - Application Mode graphics irritating Reply

    This will disable pre-selection. It you wish to disable pre-selection then it is easier to just add: set no_preselect_allegro
    to your local env file.

    If you wish to take advantage of pre-selection mode there is no way of disabling the temporary highlight of selectable elements.


    Originally posted in cdnusers.org by fxf
    • Post Points: 0
  • Thu, Oct 11 2007 7:28 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: 16.0 migration - Application Mode graphics irritating Reply

    I added the "set no_preselect_allegro" to my local env file and it works when Idle. As soon as I execute a command the elements are highlighting again depending on what is selected in the Find Filter. Is there a way to turn this off?


    Originally posted in cdnusers.org by gkurtz
    • Post Points: 0
  • Thu, Oct 11 2007 8:02 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: 16.0 migration - Application Mode graphics irritating Reply

    I see the same thing here with it not staying off. . . . I have switched back to 15.7 until the hover highlight distracting graphics can be turned off and stay turned off. I was unable to find a way to get it to stay off. It was causing such a slow down I was forced to go back to 15.7 even though I really don't want to. Now I am having another problem with the graphics being pretty slow repaint from left to right. I have a medium price card in there a GEFORCE 8600 GTS with 256 meg that should rock and roll fast but it does'nt. I have put a request into Cadence and got a reply back but no solution.


    Originally posted in cdnusers.org by dlocke
    • Post Points: 0
  • Fri, Oct 12 2007 6:47 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: 16.0 migration - Application Mode graphics irritating Reply

    Regarding slow graphics, Make sure you have the latest NVIDIA drivers installed for your graphics card. If you do have the latest drivers and graphics are still too slow you can disable OpenGL graphics and graphics performance should return to as it was in 15.7. OpenGL can be disabled from: Setup => User Preferences => OpenGL, disable_opengl .

    Randy


    Originally posted in cdnusers.org by rb
    • Post Points: 0
Page 1 of 1 (13 items)
Sort Posts:
Started by archive at 26 Sep 2007 02:26 PM. Topic has 12 replies.