Home > Community > Forums > PCB Design > Negative art layer files issue

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Negative art layer files issue 

Last post Wed, Jun 6 2007 10:49 AM by archive. 10 replies.
Started by archive 06 Jun 2007 10:49 AM. Topic has 10 replies and 1463 views
Page 1 of 1 (11 items)
Sort Posts:
  • Wed, Jun 6 2007 10:49 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    Negative art layer files issue Reply

    Hi,

    while generating artwork filesĀ it observe that negative layers did not show the Film Tiltle block (FTB) information in art files. However it present in positive layers. Any solution for it?


    Originally posted in cdnusers.org by imaqsood
    • Post Points: 0
  • Wed, Jun 6 2007 11:34 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: Negative art layer files issue Reply

    Never had a problem with that. Is the film title block class/subclass included in the negative artwork layer? Easy way to check is to select the negative layer view on the Control Panel's visibility tab.


    Originally posted in cdnusers.org by Randy R.
    • Post Points: 0
  • Wed, Jun 6 2007 11:39 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: Negative art layer files issue Reply

    make sure your manufacturing/photoplot_outline includes the title block info


    Originally posted in cdnusers.org by dryan
    • Post Points: 0
  • Wed, Jun 6 2007 10:15 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: Negative art layer files issue Reply

    yes, I have added that films in artwork and also show by visibilty option but when I tried to generate .art file and open it in gerber viewer then FTB is missing there.
    Any help?


    Originally posted in cdnusers.org by imaqsood
    • Post Points: 0
  • Wed, Jun 6 2007 10:18 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: Negative art layer files issue Reply

    yes, I have added that films in artwork and also show by visibilty option but when I tried to generate .art file and open it in gerber viewer then FTB is missing there.
    Any help?


    Originally posted in cdnusers.org by imaqsood
    • Post Points: 0
  • Wed, Jun 6 2007 10:24 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: Negative art layer files issue Reply

    yes, I have added that films in artwork and also show by visibilty option but when I tried to generate .art file and open it in gerber viewer then FTB is missing there.
    Any help?


    Originally posted in cdnusers.org by imaqsood
    • Post Points: 0
  • Thu, Jun 7 2007 4:18 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: Negative art layer files issue Reply

    This is a bit confusing but a possible reason why you do not see the Title Block is because the information is most likely present but but negative. As the text is not covered by the copper shape the text dissapears. See the sample snapshots.

    KP



    Originally posted in cdnusers.org by kp
    • Post Points: 0
  • Thu, Jun 7 2007 4:33 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: Negative art layer files issue Reply

    Yes what kp said is true.

    If you want the text to be visible try the below steps.

    1. Select the area of text and invert the same i.e change that portion to positive.
    2. Remove filled area around the text now the text will be visible.

    On more thing in few tools this region is recognized as a different entity and will appear in different layer.

    Hope this helps you.

    Thks


    Originally posted in cdnusers.org by eswar
    • Post Points: 0
  • Thu, Jun 7 2007 8:31 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: Negative art layer files issue Reply

    Have you verified that the text block has a value in the photoplot width?
    Are you using a photoplot outline? If the text is outside the outline it will not plot.
    Check for zero width lines also.

    Regards
    BillZ


    Originally posted in cdnusers.org by BillZ_EMA
    • Post Points: 0
  • Thu, Jun 7 2007 9:07 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: Negative art layer files issue Reply

    dryan had it right.
    For your negative layers to output correctly, you need to add an unfilled rectangle shape to the Manufacturing/Photoplot Outline subclass. Make sure that it bound all items you want in that layer.


    Originally posted in cdnusers.org by annoonan
    • Post Points: 0
  • Thu, Jun 7 2007 2:10 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: Negative art layer files issue Reply

    Yup, it's the PHOTOPLOT OUTLINE. Used to run into that all the time. You need to put the photoplot outline around the 'whole' area you want it to output in negative image. Or else it will only output from the board outline in.

    Be aware though. If you have the fabrication or assembly drawings inside Allegro, and the format are large, be aware when you output those. What I normally do is: 1) save the design; 2) delete the PH OUTLINE; 3) output the fab/assembly drawing; 4) exit or re-open the saved database. That way you'll get the whole drawing, and not just what's inside the PH OUTLINE.

    Good day.
    Mitch


    Originally posted in cdnusers.org by cadpro2k
    • Post Points: 0
Page 1 of 1 (11 items)
Sort Posts:
Started by archive at 06 Jun 2007 10:49 AM. Topic has 10 replies.