Home > Community > Forums > PCB Design > OrCad Layout to Allegro - Via Padstack Problem

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 OrCad Layout to Allegro - Via Padstack Problem 

Last post Wed, Feb 21 2007 10:27 AM by archive. 3 replies.
Started by archive 21 Feb 2007 10:27 AM. Topic has 3 replies and 1462 views
Page 1 of 1 (4 items)
Sort Posts:
  • Wed, Feb 21 2007 10:27 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    OrCad Layout to Allegro - Via Padstack Problem Reply

    Attempting my first Layout to Allegro translation, and am getting an error :

    ERROR (Layout To PCBEditor), Padstack 'V_TP_SM' is malformed on layer 1

    The Layout padstack is a Via being used as a Testpoint on the Bottom surface only, so it is defined as having features on Layout Bottom and Bottom Soldermask only, all other layers are undefined.

    Anyone run into a similar problem? The error logs that are created include only the information I've listed above.

    Thanks,
    Dave


    Originally posted in cdnusers.org by dschaefer
    • Post Points: 0
  • Mon, Feb 26 2007 1:45 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: OrCad Layout to Allegro - Via Padstack Problem Reply

    I hink the via needs some sort of copper feature (pad) on the top layer. Allegro normally insists on having a coonect point at either end of a hole. If you don;t want it on your manufactured board make the feature smaller than the drilled hole.


    Originally posted in cdnusers.org by emldebh
    • Post Points: 0
  • Tue, Feb 27 2007 8:48 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: OrCad Layout to Allegro - Via Padstack Problem Reply

    Turns out I need an ISR to perform the translation.

    The design now translates, but I believe you are correct about the required features as I see other issues post-translation.

    Thanks!

    Dave


    Originally posted in cdnusers.org by dschaefer
    • Post Points: 0
  • Wed, Feb 28 2007 1:43 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: OrCad Layout to Allegro - Via Padstack Problem Reply

    Have translated a few Orcad designs and have noticed a few things that do not come through correctly. Here is a partial list.

    1. Planes do not come in.
    2. No anti-pad / thermal sizes in the padstacks.
    3. SMD pads defined from the bottom whilst the package geometry is defined from the top.
    4. Silkscreens and other aesthetics not read in.
    5. Many duplicate padstacks created of the same drill and pad features.
    6. Layer count incorrect.
    7. Extra holes, such as fixings, mechanicals missing.
    8. Basic constraints do not come through correctly.
    9. Some components do not get placed due to 'out of extents'. This is caused by the reference designators being offset.
    10. Board outline and internal board cut-outs missing.

    KP


    Originally posted in cdnusers.org by kp
    • Post Points: 0
Page 1 of 1 (4 items)
Sort Posts:
Started by archive at 21 Feb 2007 10:27 AM. Topic has 3 replies.