Home > Community > Forums > PCB Design > NCDPATH bug

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 NCDPATH bug 

Last post Mon, Dec 4 2006 3:15 AM by archive. 1 replies.
Started by archive 04 Dec 2006 03:15 AM. Topic has 1 replies and 524 views
Page 1 of 1 (2 items)
Sort Posts:
  • Mon, Dec 4 2006 3:15 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    NCDPATH bug Reply

    Hello All. In SPB15.7, I have a problem with NCDPATH: the environnement variable NCDPATH is set (since a long time) to dot (.) and another common path on the network where we store our default nc_param.txt file. on the . path (the physical board path), there is no nc_param.txt at the beginning. So the common file is read and then copier to . If you change it locally then "." file is read and not anymore the common file. Since SPB15.7, the default path is not read anymore. It creates a new one in . with wrong params (true in fact but not what we want). I tried to remove the first . (dot) path and the the common network path is used. So it seems that only one path of the NCDPATH is taken, the first one. Did somebody see a similar thing? Thanks.


    Originally posted in cdnusers.org by willbi
    • Post Points: 0
  • Tue, Dec 5 2006 8:15 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: NCDPATH bug Reply

    Solved.

    In fact we use a script to generate the drill legend before running nctape command.
    This script was OK in 15.5.1 and before. But now when it runs, it creates a nc_param.txt wit two lines:
    DRILLING LAYER-PAIR
    BACKDRILL NO
    It seems these lines are informations needed to fill the legend (and it's new in 15.7)

    So I solved the problem by running the ncdrill param command at the beginning of the script.
    This makes that the default nc_params.txt file is copier to "." and like it already contains these two lines, it works.


    Originally posted in cdnusers.org by willbi
    • Post Points: 0
Page 1 of 1 (2 items)
Sort Posts:
Started by archive at 04 Dec 2006 03:15 AM. Topic has 1 replies.