Home > Community > Forums > PCB Design > Cadence Allegro Libraries

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Cadence Allegro Libraries 

Last post Mon, Jun 26 2006 9:07 AM by archive. 3 replies.
Started by archive 26 Jun 2006 09:07 AM. Topic has 3 replies and 1501 views
Page 1 of 1 (4 items)
Sort Posts:
  • Mon, Jun 26 2006 9:07 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    Cadence Allegro Libraries Reply

    Hi I'm Al and I'm new here. I'm having a problem with my Allegro libraries. I'm trying to put a schematic entry in Design Entry HDL. I seem to be missing components. I have a standard library but all I have are borders, ground and power pins. I can't find my resistors, capacitors, ICs, etc. Can you help me? I'm using Allegro Design Entry HDL 15.5. I attached a snapshot of my desktop. Did I not install Allegro properly? Thanks. Ü

    - al


    Originally posted in cdnusers.org by acbalbason
    • Post Points: 0
  • Mon, Jun 26 2006 9:35 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    RE: Cadence Allegro Libraries Reply

    Looks like you need to add your library path(s) to your cds.lib file (found in the root directory of the project you created).  This is done using the DEFINE statement:
    DEFINE discrete ./mylib/logical/discrete (example; modify for your directory paths/names).
    Then you have to add the libraries to your project.  For details, search on "cds.lib" in the help file and check out Project Setup and Creation.


    Originally posted in cdnusers.org by Randy R.
    • Post Points: 0
  • Mon, Jun 26 2006 10:35 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    RE: Cadence Allegro Libraries Reply

    If you have the libraries added to your cds.lib, you will need to move the libraries in to the project libraries list. This is done in Setup under the Global tab. Move each of the libraries to wish to access from the list of available libraries to the project libraries list.


    Originally posted in cdnusers.org by cdavies
    • Post Points: 0
  • Tue, Jun 27 2006 9:55 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    RE: Cadence Allegro Libraries Reply

    Thanks R2 and Charlie. I tried doing what you advised. What I did was I extracted zip files from the tutorials containing models and symbols, put them on a folder under the standard library ang used the DEFINE command to edit my cds.lib. What I don't understand though is, why doesn't my allegro installation have a default standard library containing basic components like resistors and capacitors. After what i did I now have these basic components but they are still incomplete. I've used previous versions before and I did not encounter this problem. Usually I have dozens of components that comes with the installation. I've searched for all files under the installation directory so that I can just point to that folder for my components, unfortunately there was none. So I had to figure out a very crude way just to have these limited components appear under my components browser. Any comments? Thank you again! Have a good day. Ü


    Originally posted in cdnusers.org by acbalbason
    • Post Points: 0
Page 1 of 1 (4 items)
Sort Posts:
Started by archive at 26 Jun 2006 09:07 AM. Topic has 3 replies.