Home > Community > Forums > PCB Design > Easier way to enable via_pop attribute on a polygon attached to a net...

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Easier way to enable via_pop attribute on a polygon attached to a net... 

Last post Mon, Jun 26 2006 8:25 AM by archive. 0 replies.
Started by archive 26 Jun 2006 08:25 AM. Topic has 0 replies and 486 views
Page 1 of 1 (1 items)
Sort Posts:
  • Mon, Jun 26 2006 8:25 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    Easier way to enable via_pop attribute on a polygon attached to a net... Reply

    Hi,

    I'm using Allegro Router v15.2 and need help with the methodology of adding the via_pop attribute to a polygon (attached to a net), within the Router tool.  I can manually edit the *.dsn file to add the attribute to the polygon, but really need to be able to do it from within a *.DO file. 

    ie. Using Allegro router with P-CAD 2004.  Have *.DO script which declares polygon pours with identical coordinates to all copper pours declared in p-cad (they do not translate between the two tools).  Allows auto-routing from Allegro, without the router plowing through all P-CAD pour locations.

    Sample lines from my *.do file:

    mode edit polygon
    edit_active_layer Top
    edit_change_conn_params (net GND)
    create_polygon_init 100 100
    create_poly_add_pt 150 100
    create_poly_add_pt 150 150
    create_poly_add_pt 100 150
    edit_poly_finish


    Thanks for any help,

    rj


    Originally posted in cdnusers.org by reuben_j
    • Post Points: 0
Page 1 of 1 (1 items)
Sort Posts:
Started by archive at 26 Jun 2006 08:25 AM. Topic has 0 replies.