Home > Community > Forums > PCB Design > Negative artwork where autovoid ?! (allegro)

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Negative artwork where autovoid ?! (allegro) 

Last post Wed, Jun 14 2006 11:06 PM by archive. 7 replies.
Started by archive 14 Jun 2006 11:06 PM. Topic has 7 replies and 1649 views
Page 1 of 1 (8 items)
Sort Posts:
  • Wed, Jun 14 2006 11:06 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    Negative artwork where autovoid ?! (allegro) Reply

    hello to all! my problem is: when mark layers NEGATIVE, allegro not create autovoid, but when layer positive - tehere is no the problem with autovoiding, what do YOU think? help me please...


    Originally posted in cdnusers.org by alchek
    • Post Points: 0
  • Thu, Jun 15 2006 1:59 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: Negative artwork where autovoid ?! (allegro) Reply

    When the stackup layers are negative no autovoids are generated. On negative board builds the voids are generated at the artwork generation stage of the design process. The only way to obtain a true wysiwyg appearance to use positive artwork layers.


    Originally posted in cdnusers.org by kp
    • Post Points: 0
  • Thu, Jun 15 2006 3:41 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: Negative artwork where autovoid ?! (allegro) Reply

    hm....thanks!

    but in older versions it was possible...


    Originally posted in cdnusers.org by alchek
    • Post Points: 0
  • Thu, Jun 15 2006 6:00 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: Negative artwork where autovoid ?! (allegro) Reply

    Can you please clarify your statement:

    "Allegro not create autovoid" when the layer is marked as NEGATIVE."

    Here is some basic question / answers regarding negative planes which you may already know about but I wanted to outline them just in case you are a new user of the tool.

    [i]Do you not see the void opening in the negative planes which represents the pin and via voids ? [/i]
    If so there is a setting under the Display tab that controls the look of negative planes.

    [i]Do you not see the pin and via void openings in your output gerber file ? [/i]
    If so you have the Plot Mode defined as Positive vs Negative.

    Negative Planes can be defined as true WYSIWYG by setting up Thermal Flash symbols that reference Flash Names in the Thermal Relief definition of the padstacks. This is not commonly used since Dynamic shapes were introduced but it is an option if you choose to use Negative Planes.


    Originally posted in cdnusers.org by mcatramb91
    • Post Points: 0
  • Thu, Jun 15 2006 7:46 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: Negative artwork where autovoid ?! (allegro) Reply

    explaining: in older versions allegro, in stackup i mark power planes like NEGATIVE and make autovoid myself (there was that option for shapes) but in 15.2 etc NO option for shapes like "autovoid shape"... and i not see visually VOIDING ( not needed vias/pins) while plane maks as NEGANIVE not in DYNAMIC not in STATIC shape. but if plane POSITIVE - vias/pins in moment becomes with VOID do you understand? (sorry for my english...) PS If so there is a setting under the Display tab that controls the look of negative planes. - which setting??? where is it? Thermal Flash symbols - earlier i'm not used flash symbols...


    Originally posted in cdnusers.org by alchek
    • Post Points: 0
  • Thu, Jun 15 2006 7:49 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: Negative artwork where autovoid ?! (allegro) Reply

    Do you not see the void opening in the negative planes which represents the pin and via voids ? yes i'm not see void


    Originally posted in cdnusers.org by alchek
    • Post Points: 0
  • Thu, Jun 15 2006 8:48 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: Negative artwork where autovoid ?! (allegro) Reply

    OK.  There is options available that replicate what you have seen on 15.2

    To add voids to a shape (Similar to 15.2)
    1. Select Shape
    2. Select pulldown Menu Shape > Manually Void > Element or Select Void Element Icon
    3. Select item to be voided or use your Right Mouse Button popup to select "Void All".

    Of course, manual void or autovoid Pins and Vias are normally done with
    Positive (Static) Shapes and are not done on Negative shapes because they
    are generated during Gerber generation. Dynamic shapes automatically get
    autovoided so there is no need to manually void Pins and Vias.

    To display Voids and Thermal markers on Negative planes select "Filled Pads"
    and "Thermal Pads" under the Display Tab in the Drawing Options Form.
    (Setup > Drawing Options)

    Hope this helps,
    Mike Catrambone
    UTStarcom, Inc.

    I also attached an image of Shape Toolbar with brief explanation of icons.


    Originally posted in cdnusers.org by mcatramb91
    • Post Points: 0
  • Thu, Jun 15 2006 11:16 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: Negative artwork where autovoid ?! (allegro) Reply

    THanks!
    is that i need ->

    To display Voids and Thermal markers on Negative planes select "Filled Pads"
    and "Thermal Pads" under the Display Tab in the Drawing Options Form.
    (Setup > Drawing Options)

    :)


    Originally posted in cdnusers.org by alchek
    • Post Points: 0
Page 1 of 1 (8 items)
Sort Posts:
Started by archive at 14 Jun 2006 11:06 PM. Topic has 7 replies.