Home > Community > Forums > Custom IC SKILL > can not open the "search"

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 can not open the "search" 

Last post Tue, Jun 13 2006 10:58 AM by archive. 13 replies.
Started by archive 13 Jun 2006 10:58 AM. Topic has 13 replies and 3525 views
Page 1 of 1 (14 items)
Sort Posts:
  • Tue, Jun 13 2006 10:58 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    can not open the "search" Reply

    Hi guys
    i have a problem that I can not open the "search" in my Cadence,  but other computers in my lab have no such problem,  is there any general reason and solution for this?
    Thanks!

    jren


    Originally posted in cdnusers.org by jren
    • Post Points: 0
  • Tue, Jun 13 2006 2:32 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    RE: can not open the "search" Reply

    Which "search" are you talking about? Which tool are you talking about (there is no tool called "Cadence")? The search could be the search in cdsdoc, in cdsFinder, in the layout editor, in the schematic editor - you need to be more explicit in your question, otherwise nobody will be able to give you an answer.

    Regards,

    Andrew.


    Originally posted in cdnusers.org by adbeckett
    • Post Points: 0
  • Fri, Jun 16 2006 12:31 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    RE: can not open the "search" Reply

    I am sorry if my question is not good, but I am trying to be more clear about that. Thanks for your patient.
    the search is in the cdsdoc.



    Originally posted in cdnusers.org by jren
    • Post Points: 0
  • Sun, Jun 18 2006 9:35 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    RE: can not open the "search" Reply

    You still don't give any details of what is the problem. What exactly happens? Please give a step by step description of what happens.

    You've said the problem is with the search in cdsdoc, but not said what the symptoms are.

    Regards,

    Andrew.


    Originally posted in cdnusers.org by adbeckett
    • Post Points: 0
  • Mon, Jun 19 2006 7:01 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    RE: can not open the "search" Reply

    ok, when I open the cdsdoc, there is a window, in the bottom of which there is a button called " search". then I open an Moxilla( I do not know if i can call internet exploer in Linux like this), after I press the button, it says, the "connection is refused".  So I can not open the search. I do not know if it is clear enough now.

    Regards
    jren


    Originally posted in cdnusers.org by jren
    • Post Points: 0
  • Mon, Jun 19 2006 1:52 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    RE: can not open the "search" Reply

    Can you run "cdsdoc -test" and post the output here?

    Regards,

    Andrew.


    Originally posted in cdnusers.org by adbeckett
    • Post Points: 0
  • Tue, Jun 20 2006 7:26 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    RE: can not open the "search" Reply

    is it this?
     CDSDoc 2.1 Installation verification

    Check system - Linux aqua.physics.sunysb.edu 2.4.21-4.ELsmp #1 SMP Fri Oct 3 17:52:56 EDT 2003 i686 i686 i386 GNU/Linux
    Checking installation directory... Done.
    Checking user environment variables... Done.
    Checking Netscape, make sure Netscape 4.51 (or higher) is in your PATH ...

              --- Warning: Netscape NOT found ---

    Checking Directory Structure...
    Directory Structure Check passed
    Done.


    Originally posted in cdnusers.org by jren
    • Post Points: 0
  • Fri, Oct 20 2006 12:27 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    RE: can not open the "search" Reply

    I have been attempting to make the Help button work as well. I have found some documentation that suggests that a symbolic link in your path to "mozilla" and called netscape will work. (I have done this with limited success!)


    Originally posted in cdnusers.org by vdvalk
    • Post Points: 0
  • Fri, Jan 19 2007 8:47 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    RE: can not open the "search" Reply

    Try setting the "CDS_DEFAULT_BROWSER" environment variable. For example, I prefer to use firefox so I have:

    setenv CDS_DEFAULT_BROWSER firefox

    ...set in my .cshrc file. In the case of using mozilla instead of netscape, try this:

    setenv CDS_DEFAULT_BROWSER "mozilla"

    See "Choosing a default browser" in Chapter 6 of the CDSDoc User Guide: http://sourcelink.cadence.com/docs/files/Release_Info/Docs/cdsuser/cdsuser2.3/setPrefs.html#1033081

    Enjoy!

    Andrew.


    Originally posted in cdnusers.org by aplumb
    • Post Points: 0
  • Tue, Feb 13 2007 1:08 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    RE: can not open the "search" Reply

    I know its not the place to ask the question which is not related to Skill.
    But since the question had been asked, and that I have the same problem
    I tried your solution :
    in my .bashrc I put:
    CDS_DEFAULT_BROWSER=mozilla; export CDS_DEFAULT_BROWSER;

    Still the cdsdoc button "search" gives the following pop-up error :
    Error CDSDoc-002: Viewer can't start
    The web browser can't be started. On UNIX, make sure that your PATH environment variable includes the path to Netscape. On Windows/NT, make sure that either Internet Explorer 5.0 (or highrt) or Netscape 4.5.1 (or higher) is installed with standard registry entries.

    So if anyone has another idea since I cannot go to sourcelink.cadence.com ($login$ required) and cannot acces to Chapter 6 of the CDSDoc User Guide...

    Regards,


    Originally posted in cdnusers.org by ebecheto
    • Post Points: 0
  • Tue, Feb 13 2007 1:49 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    RE: can not open the "search" Reply

    Are you using IC5141? If so, CDS_DEFAULT_BROWSER is not supported in the version of cdsdoc that comes with IC5141.

    Regards,

    Andrew.


    Originally posted in cdnusers.org by adbeckett
    • Post Points: 0
  • Tue, Feb 13 2007 2:18 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    RE: can not open the "search" Reply

    Indeed, I use :
    IC-5.1/tools.lnx86/dfII/
    sub-version 5.10.41.169

    which mean that I do not have other solution than install Netscape ?!
    Do I need to pay anything to go to sourcelink.cadence.com to have acces to the online cadence help ??

    Thanks for you help anyhow


    Originally posted in cdnusers.org by ebecheto
    • Post Points: 0
  • Tue, Feb 13 2007 2:32 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    RE: can not open the "search" Reply

    No, you don't have to install netscape. Simply create a little wrapper script called netscape which invokes mozilla inside. For example:

    #!/bin/sh
    exec mozilla "$@"

    And make sure this is in your path.

    BTW, you're using the initial (Base) release of IC5141 - that's pretty old, and there have been a lot of updates since then.

    Access to sourcelink is for customers on maintenance - you need to register using the hostid of your license server. If you're from a university (I don't know...), then you may not be able to access sourcelink - it depends on the university program (if you're under a university program). I guess you could try registering and seeing what happens!

    Regards,

    Andrew.


    Originally posted in cdnusers.org by adbeckett
    • Post Points: 0
  • Tue, Feb 13 2007 4:05 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,950
    RE: can not open the "search" Reply

    thanks ! Indeed, I found the ID to create my account for sourcelink,
    AND
    you solution works, whereas i tried before posting, a simple
    alias netscape='mozilla'
    that was not working, but a simple "sh ... exec " as you suggested work.
    Many thanks


    Originally posted in cdnusers.org by ebecheto
    • Post Points: 0
Page 1 of 1 (14 items)
Sort Posts:
Started by archive at 13 Jun 2006 10:58 AM. Topic has 13 replies.