Home > Community > Forums > Custom IC Design > Drain & Source are swapped in netlist after Assura RCX!! Help me please!

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Drain & Source are swapped in netlist after Assura RCX!! Help me please! 

Last post Wed, Sep 12 2007 7:59 AM by archive. 2 replies.
Started by archive 12 Sep 2007 07:59 AM. Topic has 2 replies and 1210 views
Page 1 of 1 (3 items)
Sort Posts:
  • Wed, Sep 12 2007 7:59 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    Drain & Source are swapped in netlist after Assura RCX!! Help me please! Reply

    Hi,

    I'm working on the phisical verification using an Assura flow, there's
    two files: RSF_pre and T35FL.pre .. The first is the control file, and the other is the rules file.
    When running:
    >> assura RSF_pre
    and checking the output netlist, I noticed that all MOSFET transistors
    have thier Source and drain swapped!!! What is the possible reason
    that can cause such swapping???

    BTW, where can I find documents about this topic? I have Cadence and Assura installed at my company.

    Could any one help me please?
    Thanks in advance,
    Ahmad


    Originally posted in cdnusers.org by ahmad_abdulghany
    • Post Points: 0
  • Wed, Sep 12 2007 2:44 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: Drain & Source are swapped in netlist after Assura RCX!! Help me please! Reply

    Did you check the pins in the layout & symbol? Is the schematic hooked up correctly (symbols are not upside down or something)?


    Originally posted in cdnusers.org by bthayer
    • Post Points: 0
  • Wed, Sep 12 2007 11:00 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: Drain & Source are swapped in netlist after Assura RCX!! Help me please! Reply

    Posted By bthayer on 9/12/2007 2:44 PM
    Did you check the pins in the layout & symbol? Is the schematic hooked up correctly (symbols are not upside down or something)?


    Thank you for replying...

    Actually, I don't have the schematic, But I compared extraction results against Calibre results, and Calibre is more convinient with the layout file i have.
    I think this is a rule file issue..
    Any other suggestion?

    Thanks again,
    Ahmad


    Originally posted in cdnusers.org by ahmad_abdulghany
    • Post Points: 0
Page 1 of 1 (3 items)
Sort Posts:
Started by archive at 12 Sep 2007 07:59 AM. Topic has 2 replies.