Home > Community > Forums > PCB Design > Assign Pattern option ( disable or a way to set it )

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Assign Pattern option ( disable or a way to set it ) 

Last post Mon, Jul 14 2014 7:24 AM by mcatramb91. 8 replies.
Started by Quarkdog1 03 Jul 2014 09:16 AM. Topic has 8 replies and 416 views
Page 1 of 1 (9 items)
Sort Posts:
  • Thu, Jul 3 2014 9:16 AM

    • Quarkdog1
    • Top 500 Contributor
    • Joined on Thu, Nov 3 2011
    • Posts 17
    • Points 220
    Assign Pattern option ( disable or a way to set it ) Reply

     I am using the funckey "code below" and now with v16.5 a "Assign Pattern" window is popping up.   I am trying to either set the pattern or disable it completely so my "F" key is more effective.

     Thanks in advance for the reply :)

     

    funckey F "generaledit; prepopup ; pop dyn_option_select 'Selection set@:@Clear all selections' ; set prompt ; prompt 'Enter Ref Des (on next step click pattern to keep it highlighted' ; refdes $prompt ; zoom selection; hilight  ;generaledit "

    • Post Points: 20
  • Thu, Jul 3 2014 10:09 AM

    • mcatramb91
    • Top 75 Contributor
    • Joined on Thu, Jan 3 2013
    • Chelmsford, MA
    • Posts 99
    • Points 4,955
    Re: Assign Pattern option ( disable or a way to set it ) Reply

    The Assign Pattern window is showing up because you have a selected component when the command "hilight" is ran.  If you remove the "; hilight" from the funckey command you should be good to go.  The Highlight command (Hilight) has changed in 16.5 and now support pattern highlighting instead of just a single highlight stripe "candy stripe", this is why you are seeing the Assign Pattern window that you haven't seen previously.

    Hope this helps,
    Mike Catrambone

     

    • Post Points: 20
  • Thu, Jul 3 2014 11:07 AM

    • Quarkdog1
    • Top 500 Contributor
    • Joined on Thu, Nov 3 2011
    • Posts 17
    • Points 220
    Re: Assign Pattern option ( disable or a way to set it ) Reply

    Hi Mike,

     If I remove the Hilight, then the component does not stay highlighted.  My use case is to "F" which highlights part and jumps. And stays highlighted while I do another "F"

    • Post Points: 20
  • Thu, Jul 3 2014 11:38 AM

    • mcatramb91
    • Top 75 Contributor
    • Joined on Thu, Jan 3 2013
    • Chelmsford, MA
    • Posts 99
    • Points 4,955
    Re: Assign Pattern option ( disable or a way to set it ) Reply

    Hi,

    I was wondering why you had "hilite" in the command in the first place.  It works for me without the "hilite".  Once I run the command it jumps to the entered RefDes.  The lower right corner of the GUI shows 1 selected object (pre-selected) and that is what zoom selection is centering on.

    Maybe you have something in your environment that is causing it not to work.  I would rename you PCBENV/ENV and create a new one with the first line being source $TELENV and the second line your Function Key alias and give it another try.  Here is an example:

    source $TELENV

    funckey F "generaledit; prepopup ; pop dyn_option_select 'Selection set@:@Clear all selections' ; set prompt ; prompt 'Enter Ref Des (on next step click pattern to keep it highlighted' ; refdes $prompt ; zoom selection ;generaledit "

    • Post Points: 20
  • Thu, Jul 3 2014 1:05 PM

    • Quarkdog1
    • Top 500 Contributor
    • Joined on Thu, Nov 3 2011
    • Posts 17
    • Points 220
    Re: Assign Pattern option ( disable or a way to set it ) Reply

    Thanks for the advice.  I ran a new env setup but unfortunately i also have to contend with a site.env that is used for our company site setup.  My guess its set in the user preferences section but have not had any luck tracking it down yet. 

    • Post Points: 20
  • Thu, Jul 3 2014 2:24 PM

    • mcatramb91
    • Top 75 Contributor
    • Joined on Thu, Jan 3 2013
    • Chelmsford, MA
    • Posts 99
    • Points 4,955
    Re: Assign Pattern option ( disable or a way to set it ) Reply

    You can run Allegro in Safe mode (allegro -safe) which will bypass all of the special environmental settings but you will need to cut and paste the funckey alias on the Allegro command line.  You may be able to do it but you will need to remove some of the extra spaces before and after the semicolons so it can be pasted without having it wrap to a new line.

    Good luck,
    Mike Catrambone

     

    • Post Points: 35
  • Thu, Jul 3 2014 3:13 PM

    • Quarkdog1
    • Top 500 Contributor
    • Joined on Thu, Nov 3 2011
    • Posts 17
    • Points 220
    Re: Assign Pattern option ( disable or a way to set it ) Reply

    Gave it a try but it still only works if I put the hilight in the CIW  :(      Thanks for all your help,  I go on three weeks of vacation now  :)

    • Post Points: 5
  • Fri, Jul 4 2014 10:40 AM

    • Quarkdog1
    • Top 500 Contributor
    • Joined on Thu, Nov 3 2011
    • Posts 17
    • Points 220
    Re: Assign Pattern option ( disable or a way to set it ) Reply

    Hi Mike, thanks again for all your insight.  Changing the "code line"  to be able to paste into the CIW area sped up my debugging greatly.  Here is my finished work around for the way my system acts. Its likely this can be shortened down but it is working  :)

    funckey F 'generaledit;set prompt;prompt 'Enter Ref Des';refdes $prompt;zoom selection;generaledit;pick grid 1.0 1.4;generaledit;hilight;setwindow form.find;FORM find name_type Symbol (or Pin);FORM find find_name $prompt;setwindow pcb;generaledit'

    • Post Points: 20
  • Mon, Jul 14 2014 7:24 AM

    • mcatramb91
    • Top 75 Contributor
    • Joined on Thu, Jan 3 2013
    • Chelmsford, MA
    • Posts 99
    • Points 4,955
    Re: Assign Pattern option ( disable or a way to set it ) Reply
    Hello,

    I am glad you were able to figure out a way to get your command to work.  One final thing to check is if you have the environmental variable APPMODE set to NONE. This can be set in the Allegro ENV file or at the OS level.  You can verify this by starting Allegro and typing 'set' on the Allegro command line to see all of the environmental settings then check if APPMODE is set to NONE,  you will not see it at all if it hasn't be explicitly set in your environment.  You can also check it by accessed the User Preferences Editor under the UI Category in the App_modes folder.  Setting APPMODE to NONE did cause the command without Highlight to fail.

    You got it working anyway but I figured you can check this one last thing so you can use the much shorter string of commands.

    Good Luck,
    Mike Catrambone
    • Post Points: 5
Page 1 of 1 (9 items)
Sort Posts:
Started by Quarkdog1 at 03 Jul 2014 09:16 AM. Topic has 8 replies.