Home > Community > Forums > Custom IC Design > "simulation data not available" problem

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 "simulation data not available" problem 

Last post Wed, May 14 2008 10:47 AM by archive. 4 replies.
Started by archive 14 May 2008 10:47 AM. Topic has 4 replies and 3133 views
Page 1 of 1 (5 items)
Sort Posts:
  • Wed, May 14 2008 10:47 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    "simulation data not available" problem Reply

    Hello,

    I used "tran" analysis for a simulation, with simulation setup all correct (ie. same setup as my prev. known good ones). Indeed, simulation finished, and the tran.tran file was about 290 Giga. However, when I used plot to see nodes' voltage/current, it said the wavefore data was not available, and then it crashed the whole "icfb" tool kits.

    I am wondering if this is a bug, or a limitation that I was not aware before. This happened several times so I am wondering if there is a solution for it. Thank you !

    san



    Originally posted in cdnusers.org by sz5g
    • Post Points: 0
  • Wed, May 14 2008 12:28 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: "simulation data not available" problem Reply

    A simulator can sequentially write out the data to a massive file as it goes along.

    However, to plot the waveforms, it has to load the data for that waveform into memory. Given that the waveform tool is a 32 bit executable, the absolute maximum memory it can use is 4G (2^32 bytes). Given that there's some overhead over what is stored on disk, it's not hard for you to run out of memory...

    290G is pretty massive. You might want to try to cut down the amount of data. Save less waveforms, and you might want to cut down the number of points in the results database (e.g. skipcount, starttime, strobeperiod - lots of options).

    Andrew.


    Originally posted in cdnusers.org by adbeckett
    • Post Points: 0
  • Tue, May 20 2008 10:43 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: "simulation data not available" problem Reply

    After you pare down your data set from 290GB to something in the single digits you can get more mileage with these two points:

    a. Save to sst2 or psfbinf instead of psfbin. Psfbinf saves as floats instead of doubles, increasing (2x) your memory capacity. You will need a recent version of Spectre for this. To enable this, quit ADE, then set either of these options:
    .cdsenv: spectre.envOpts simOutputFormat string "psfbinf"
    .cdsinit: envSetVal("spectre.envOpts" "simOutputFormat" 'string "psfbinf")
    b. Only load a subset of the results into wavescan. From the Wavescan "Results Browser", use Settings->Select Data and select a range of results to load.

    -Samir Jafferali


    Originally posted in cdnusers.org by AMSamirj
    • Post Points: 0
  • Tue, May 27 2008 5:59 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: "simulation data not available" problem Reply

    My system is a true 64-bit linux version, though limited memory capacity. Seems even I did not save any waveform for any nodes or nets, it still generated a tran.tran.tra file about 40 G. This simulation is not very critical so I actually ignored this paracity-included simulation, instead, just use a purely schematic simulation.

    I also play a bit what Samir suggested. However, do not know why "Select Data" is not active in the Setting menu. I am using version 5.10.41.

    Thank you very much for very helpful suggestions.


    Originally posted in cdnusers.org by sz5g
    • Post Points: 0
  • Wed, May 28 2008 3:11 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: "simulation data not available" problem Reply

    In ADE, you probably have it set to save all voltages. Look at Outputs->Save All and change the voltages to "selected". Then save the nets you're interested in.

    Perhaps you're not using wavescan as the viewer, but using the older AWD viewer?

    Either way, you probably still need to resolve the huge file. No point producing enormous data files if you can't view them. Just because you have a 64-bit system, does not mean you'll be able to view the data if using a 32-bit application...

    Regards,

    Andrew.


    Originally posted in cdnusers.org by adbeckett
    • Post Points: 0
Page 1 of 1 (5 items)
Sort Posts:
Started by archive at 14 May 2008 10:47 AM. Topic has 4 replies.