Home > Community > Forums > Custom IC Design > Spectre in IC6.1.6

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Spectre in IC6.1.6 

Last post Tue, Feb 25 2014 10:17 AM by Tawna. 1 replies.
Started by Kaou 25 Feb 2014 09:46 AM. Topic has 1 replies and 1005 views
Page 1 of 1 (2 items)
Sort Posts:
  • Tue, Feb 25 2014 9:46 AM

    • Kaou
    • Not Ranked
    • Joined on Thu, Sep 13 2012
    • East Lansing, MI
    • Posts 7
    • Points 110
    Spectre in IC6.1.6 Reply

    I am trying to run a simulation, ADE fails after the "start simulator if needed..." with an error:

    ERROR (ADE-3036): Errors encountered during simulation. The simulator run log has not been generated.

    Possible cause could be an invalid command line option for the version of the simulator

    you are running. Choose Setup->Environment and verify that the command line options

    specified in the userCmdLineOption field are supported for the simulator.

    Alternatively, run the simulator standalone using the runSimulation file in the netlist

    directory to know the exact cause of the error.

     

    The userCmdLineOption is blank, and trying to execute runSimulation gives:

    Fatal error in MPI_Init: Other MPI error, error stack:
    MPIR_Init_thread(420)..............:
    MPID_Init(180).....................: channel initialization failed
    MPIDI_CH3_Init(38).................:
    MPID_nem_init(244).................:
    MPID_nem_tcp_init(108).............:
    MPID_nem_tcp_get_business_card(354):
    MPID_nem_tcp_init(313).............: gethostbyname failed, <redacted> (errno 1)

     

    For reference, runSimulation has the following:

    spectre  input.scs +escchars +log ../psf/spectre.out +inter=mpsc +mpssession=spectre0_8891_2  -format psfxl -raw ../psf  -I/opt/Cadence/NCSU-CDK-1.6.0.beta/models/spectre/nom +lqtimeout 900 -maxw 5 -maxn 5  

     

    checkSysConf is passing for both IC6.1.6 and MMSIM13.10, is there somewhere else to check whether the package dependencies are being met?

    • Post Points: 20
  • Tue, Feb 25 2014 10:17 AM

    • Tawna
    • Top 25 Contributor
    • Joined on Thu, Jul 10 2008
    • Snohomish, WA
    • Posts 212
    • Points 5,625
    Re: Spectre in IC6.1.6 Reply

    Hi Kaou,

     This really is an issue that should be handled by Customer Support.   It is going to take some debugging, I suspect.  

    If you type "spectre -W" command at the unix prompt, do you get this error message?

    If so, Article 20228234 ( http://support.cadence.com/wps/mypoc/cos?uri=deeplinkmin:ViewSolution;solutionNumber=20228234) suggests the following:

    The reason you are getting this error is because the hostname for the system is not getting resolved properly. 

    Kindly check hostname is set appropriately and correct entry to this host is added to /etc/hosts file.

    For example, you should have something like this in /etc/hosts file:

     

    172.23.43.247 rl-tsam rl-tsam.compname.com

     

    whereby the hostname is rl-tsam.

     

    best regards,

    Tawna

    Best regards, Tawna Wilsey Staff Support AE, Global Customer Support Cadence Design Systems, Inc.
    • Post Points: 5
Page 1 of 1 (2 items)
Sort Posts:
Started by Kaou at 25 Feb 2014 09:46 AM. Topic has 1 replies.