Home > Community > Forums > Digital Implementation > ELC do not recognizing spectre format model file well

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 ELC do not recognizing spectre format model file well 

Last post Wed, Feb 19 2014 12:20 PM by Willvlsi. 0 replies.
Started by Willvlsi 19 Feb 2014 12:20 PM. Topic has 0 replies and 1310 views
Page 1 of 1 (1 items)
Sort Posts:
  • Wed, Feb 19 2014 12:20 PM

    • Willvlsi
    • Not Ranked
    • Joined on Fri, Feb 7 2014
    • Posts 6
    • Points 75
    ELC do not recognizing spectre format model file well Reply

    Hi, all

    I am doing std cell characterazation using ELC. And I use a model file from TSMC, it defines multiple sections for different processes and corner. At each section, it defines many parameters which has unique values to that process and/or corner, then it include the mos model which uses these parameter to describe its characters. The ELC could direct into the right section and include the mos model well, but it seems it does not recognize the parameter definition. It reports errors when I do "db_spice". Reported errors like:

    Error found by spectre during hierarchy flattening. ERROR (SFE-1999): "/home/abc/works/elc/foo.ipdb/NCH.device/simulate/model" 4: Model `nch.1': parameter `wmin': Unknown parameter name `dxw' found in expression.

    This model file works well with spectre in virtuoso, but not with ELC.  

    Anybody could help me with this? Thanks in advance!

    ps. In the elcUG dorcument, under the SPICE Input directory, it said "An optional parameter library file, which defines the device parameters for different process corners" but no more detials following. Anyone know how to write this file and how to include it in ELC project?

    • Post Points: 5
Page 1 of 1 (1 items)
Sort Posts:
Started by Willvlsi at 19 Feb 2014 12:20 PM. Topic has 0 replies.