Home > Community > Forums > PCB Design > ORCIS-6085 Could Not read part information

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 ORCIS-6085 Could Not read part information 

Last post Wed, Mar 12 2014 12:50 PM by cyclops116. 4 replies.
Started by cyclops116 24 Jan 2014 11:48 AM. Topic has 4 replies and 4492 views
Page 1 of 1 (5 items)
Sort Posts:
  • Fri, Jan 24 2014 11:48 AM

    • cyclops116
    • Not Ranked
    • Joined on Wed, Jan 22 2014
    • Posts 3
    • Points 30
    ORCIS-6085 Could Not read part information Reply

    Ok I'm not a user of Orcad CIS I am the IT guy supporting the people using it so forgive me if I use the wrong terms or have trouble explaining.

    So our system is this

    Using Version 16.5 have tested with 16.6 latest hotfix. Shared licenses hosted on a server.  Shared Library file(.olb) in a file share on the server, mapped in Capture through the Capture.ini file.  We also use CIP as the parts database.  

    Engineer makes the design the passes it to a tech.  The tech updates the parts in the design to match them with CIP.  If a part comes up red in Part Manger the Tech goes in and links the parts to the proper one in the database.  Then the Tech runs the BOM to send to our vendor to manufacture the board.  
    Now the issue, 

    Randomly

    When the Tech right clicks the red lighted part and hits link part it brings up the link part window, we can see the single part in the DB or multiple parts that match it (looks to me like the list is generataed from the CIP DB), when he chooses the part we get an this error,
    "Warning [ORCIS-6085] Could not read part information for XXXX." Then everything turns red.  We can update the part from the OLB file in the Cache, AND pretty sure it's getting the part list from CIP.  So I here are my questions

    1. Where is it trying to look to get that part information if not the olb file or CIP?  

     2. What would cause this? 

    3. Is there a place I can go to look what the ORCIS errors mean so I don't have to contact support or write these super long posts in this forum :)  

     Now when I say randomly it happens a couple times a week and nothing I do fixes it, we just have to wait 30 to 60 min and it clears up it self. I've checked the network for something using all the bandwidth, the servers aren't doing anything but serving files, no one is uploading or downloading huge amounts of data etc.

    It also doesn't happen to everyone at the same time, one person can be in and working fine and someone else will be having this issue. I also happens when no one else is in!

    PLEASE HELP before they string me up! 

    • Post Points: 20
  • Fri, Jan 24 2014 12:04 PM

    • oldmouldy
    • Top 10 Contributor
    • Joined on Tue, Jul 15 2008
    • Woking, Surrey
    • Posts 1,446
    • Points 24,595
    Re: ORCIS-6085 Could Not read part information Reply

    The "part information" in question is the schematic part from the OLB file, that's all. Check that no other user(s) have the library as a "project library", this will lock the library when they open the project that relates the library. (Libraries added to "Part Selector Configured Libraries", or "Part Library Directories" which you are likely using for CIP, in the Capture.ini file are never locked) but libraries added into the OPJ file are locked when the project is opened. Also, try to confirm that users are not editing / updating OLB file entries while other users are trying to "consume" the data in the files through CIS / CIP, this may explain the "random" nature of not being able to read the OLB file data.

    • Post Points: 35
  • Fri, Jan 24 2014 12:12 PM

    • cyclops116
    • Not Ranked
    • Joined on Wed, Jan 22 2014
    • Posts 3
    • Points 30
    Re: ORCIS-6085 Could Not read part information Reply

    Thanks for the quick reply!    

    If it's the OLB file is locked, wouldn't it block the update in the cache for the design?  

    That being said HOW can we use a shared .olb file if it can only be used by a single user?  Is there something I can do with file rights or configurations that will stop this?   

    • Post Points: 5
  • Wed, Mar 12 2014 9:40 AM

    Re: ORCIS-6085 Could Not read part information Reply

     We have the same problem with sharing .olb files. I'm trying to understand your explanation of the OPJ files.  We are sharing on the network a library Shared.olb.  Shared.olb has it's own OPJ file. Then I have My.dsn file which has an associated My.opj.  My coworker has His.dsn with His.opj and he is also using Shared.olb

     

    1) Which OPJ file are you referring to?

    2) How would olb files get "added" to an OPJ file?

    3) How do we avoid these problems with shared olb files?

    • Post Points: 20
  • Wed, Mar 12 2014 12:50 PM

    • cyclops116
    • Not Ranked
    • Joined on Wed, Jan 22 2014
    • Posts 3
    • Points 30
    Re: ORCIS-6085 Could Not read part information Reply

    Not sure about OPJ files but I did finally get this fixed.

    We were using UNC paths in the ini files, which is supposed to be ok BUT with UNC paths the connection to the server would time out after a while if the user wasn't directly using it - eg. actively accessing the olb files.   So if he stopped looking at it and let it sit for 30 min or so it would basically disconnect then wouldn't be able to find the olb file again.

    I changed the ini to use a mapped drive and haven't had an issue since the day after I posted the original question. 

     

    • Post Points: 5
Page 1 of 1 (5 items)
Sort Posts:
Started by cyclops116 at 24 Jan 2014 11:48 AM. Topic has 4 replies.