Home > Community > Forums > Custom IC Design > Problem in simulating a circuit with spectre

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Problem in simulating a circuit with spectre 

Last post Mon, Dec 16 2013 1:37 AM by Andrew Beckett. 1 replies.
Started by pdatta 13 Dec 2013 09:12 PM. Topic has 1 replies and 1004 views
Page 1 of 1 (2 items)
Sort Posts:
  • Fri, Dec 13 2013 9:12 PM

    • pdatta
    • Not Ranked
    • Joined on Thu, Nov 28 2013
    • Posts 1
    • Points 20
    Problem in simulating a circuit with spectre Reply

    Hi

    I am new with linux and cadence. So, the problem I am facing may be a very simple one. But I couldn't find any solution in google and hence, I'm posting. I installed Cadence custom IC 6.15 and MMSIM 12 using iscape in ubuntu 12.04 32 bit OS.Then I installed NCSU freepdk45. Everything seem to work fine. When I run virtuoso, no error or warning in the cds.log file.

    But problem occurs when I try to simulate a circuit. I tried to simulate with spectre (I don't have license for hspice). In doing the simulation I did the following things:

    1. Initialize the spectre (simulation run directory: spectre.runl).

    2. Lunch ADE L, choose simulator/directory/host

    3. define model card path, set the stimuli 

    4. choose the analysis,  select outputs to be plotted on schematic

    5. then choose netlist and run.

    When all of these are done I get an error message in the cds.log stating:

    ERROR (ADE-3036): Errors encountered during simulation. The simulator run log has not been generated.

            Possible cause could be an invalid command line option for the version of the simulator

            you are running. Choose Setup->Environment and verify that the command line options

            specified in the userCmdLineOption field are supported for the simulator.

            Alternatively, run the simulator standalone using the runSimulation file in the netlist

            directory to know the exact cause of the error. 

    So, if you please help me solving this problem, I would really appreciate it.

    Palash Datta 

    Filed under: ,
    • Post Points: 20
  • Mon, Dec 16 2013 1:37 AM

    Re: Problem in simulating a circuit with spectre Reply

    Hi Palash.

    Ubuntu is not a supported OS, but it's probably more the fact that you're using a 32-bit OS that is the issue. MMSIM11.1 onwards (I think) requires you to be using a 64-bit OS and will fail otherwise.

    You can probably check this easily by trying to invoke the "runSimulation" script in the netlist directory as the error message suggests.

    Regards,

    Andrew.

    • Post Points: 5
Page 1 of 1 (2 items)
Sort Posts:
Started by pdatta at 13 Dec 2013 09:12 PM. Topic has 1 replies.