Home > Community > Forums > PCB Design > PSPICE Error S2C3471 Base part library does not exist

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 PSPICE Error S2C3471 Base part library does not exist 

Last post Fri, Oct 4 2013 7:42 AM by EEdesign1. 2 replies.
Started by EEdesign1 03 Oct 2013 02:12 PM. Topic has 2 replies and 362 views
Page 1 of 1 (3 items)
Sort Posts:
  • Thu, Oct 3 2013 2:12 PM

    • EEdesign1
    • Not Ranked
    • Joined on Thu, Sep 3 2009
    • Posts 2
    • Points 25
    PSPICE Error S2C3471 Base part library does not exist Reply

    When using model editor to export a TI LMH6629 SPICE model, I get:

    STATUS: PSpice Schematics to Capture translator (16.6.0.d001)
    STATUS: 
    STATUS: Translator started at Thursday, October 03, 2013 16:31:52
    STATUS: C:\Cadence\SPB_16.6\tools\Capture\sch2cap -f INFO(ORSCH-1029): Using existing library 

      ERROR: [S2C3471] Base part library  does not exist


    STATUS: Translator stopped at Thursday, October 03, 2013 16:31:53
    STATUS: 1 Error messages, 0 Warning messages 

    Which, from my interpretation, tells me Model Editor cannot find the models in my text file:

    .MODEL QDP PNP

    .MODEL QDN NPN

    .MODEL QON NPN VAF=150 BF=420 IKF=1.5 RE=0.5 RC=1

    .MODEL QOP PNP VAF=150 BF=420 IKF=1.5 RE=0.5 RC=1

    .MODEL QIP PNP VAF=150 BF=260 IKF=0.005 RB=1.4 RE=0.1 RC=1

    .MODEL DVN D KF=4E-13

    .MODEL DIN D KF=26E-14

    .MODEL DIC D RS=0.1

    .MODEL DD D

    .MODEL PSW PMOS KP=200U VTO=-7.5 IS=1E-18

    .MODEL NSW NMOS KP=200U VTO=7.5 IS=1E-18

    .MODEL QSW NPN

    .MODEL NEN NMOS KP=200U VTO=0.5 IS=1E-18

    Where are the NPN, PNP, D, NMOS, etc models located?   In what .lib file?   I have searched through the SPB_16.6 PSPICE libraries and cannot find them. Thanks.

     

    Filed under:
    • Post Points: 20
  • Thu, Oct 3 2013 8:59 PM

    • alokt
    • Top 25 Contributor
    • Joined on Fri, Aug 22 2008
    • Noida, Uttar Pradesh
    • Posts 239
    • Points 3,445
    Re: PSPICE Error S2C3471 Base part library does not exist Reply

    Your goal is not clear. What exactly are you trying to accomplish? Commend mentioned by you would generate the symbol library. These symbols are used to create schematic/designs. Is this the goal? Why? Since you installation already has symbol libraries for all models shipped with it. 

    Are you using licensed version or Lite (Demo ) version ? Note that Lite version support limited capabilities?

    Answer to these questions would help others in providing exact input.

    • Post Points: 20
  • Fri, Oct 4 2013 7:42 AM

    • EEdesign1
    • Not Ranked
    • Joined on Thu, Sep 3 2009
    • Posts 2
    • Points 25
    Re: PSPICE Error S2C3471 Base part library does not exist Reply

    Thank-you for the response.

    The goal is to export the TI OpAmp PSPICE file to a .lib file for use in a simulation. The licensed version of SPB 16.6 does not have a model for the LMH6629. The error shown seems to indicate Model Editor cannot find the files for Models NPN, PNP, D, PMOS, NMOS, however, I am not 100% certain, and I do not know what .LIB file the NPN, PNP, D, PMOS, NMOS models are kept.

     

    • Post Points: 5
Page 1 of 1 (3 items)
Sort Posts:
Started by EEdesign1 at 03 Oct 2013 02:12 PM. Topic has 2 replies.