Home > Community > Forums > Custom IC Design > Why the l(m) and w(m) are always set 5e-06m in model parameter field after any simulation?

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Why the l(m) and w(m) are always set 5e-06m in model parameter field after any simulation? 

Last post Fri, Sep 6 2013 11:06 AM by Alex Liao. 2 replies.
Started by Alex Liao 05 Sep 2013 01:39 PM. Topic has 2 replies and 241 views
Page 1 of 1 (3 items)
Sort Posts:
  • Thu, Sep 5 2013 1:39 PM

    • Alex Liao
    • Top 200 Contributor
    • Joined on Wed, May 22 2013
    • Posts 37
    • Points 575
    Why the l(m) and w(m) are always set 5e-06m in model parameter field after any simulation? Reply

    Hi,

    I have checked the netlist which corresponds to my design with respect to my setting on w/l of devices. But when I PRINT MODEL PARAMETER, the w and l fields are always keep unchanged, 5 um and this finding is further found in model parameter -info using Cadence result browser. Is this w and l meaning channel width and length? why they are set so?



    Regards,
    Alex

    • Post Points: 20
  • Thu, Sep 5 2013 9:25 PM

    Re: Why the l(m) and w(m) are always set 5e-06m in model parameter field after any simulation? Reply

    Hi Alex,

    From the "Model Parameters" section of "spectre -h bsim4":

    484     w=5e-6 m          Default channel width.
    485     l=5e-6 m          Default channel length.

    So the model can define the default value of w and l if not specified on the instance. And there are default values of those defaults...

    Since you are looking at the model parameters (rather than instance parameters) you're simply seeing the values of those defaults. You would not expect (as I've explained in previous posts) to see instance parameters affecting dumped model parameters; after all, the same model is shared amongst multiple instances, regardless of the w and l of each instance.

    Regards,

    Andrew.

    • Post Points: 20
  • Fri, Sep 6 2013 11:06 AM

    • Alex Liao
    • Top 200 Contributor
    • Joined on Wed, May 22 2013
    • Posts 37
    • Points 575
    Re: Why the l(m) and w(m) are always set 5e-06m in model parameter field after any simulation? Reply

    Hi Andrew,

     Got you. The netlist takes w and l from instance parameters first, if not set then takes values from model parameter list which gives default value. The default value in model parameter list is set so that it provides a universe value for all devices to refer to.

     Thanks,

    Alex 

    • Post Points: 5
Page 1 of 1 (3 items)
Sort Posts:
Started by Alex Liao at 05 Sep 2013 01:39 PM. Topic has 2 replies.