Home > Community > Forums > Custom IC Design > save option not working for ac within transient

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 save option not working for ac within transient 

Last post Fri, Sep 6 2013 2:18 PM by Andrew Beckett. 5 replies.
Started by Steve Mikes 05 Sep 2013 10:15 AM. Topic has 5 replies and 369 views
Page 1 of 1 (6 items)
Sort Posts:
  • Thu, Sep 5 2013 10:15 AM

    save option not working for ac within transient Reply

    I'm running a transient sim and using the actimes option to run ac analysis at various points. 

     

     tran_ac tran stop=150u errpreset=moderate write="spectre.ic" method=trapgear2 \

         writefinal="spectre.fc" annotate=status flushtime=60 \

         strobeperiod=250n save=selected \

         maxiters=5 acnames=[ac_single] actimes=mytimes

    ac_single ac freq=frf annotate=status save=selected

    save VCAP V1:p

     

    The ac analyses that are run do not seem to be able to "find" the save statement in the netlist. When save=selected doesn't find any selected nets, it reverts to save=allpub, so I end up with all voltages and don't have the current I wanted. If I change the save in the ac analysis to save=none, I get nothing, so it does respond to the statement. Right now as a work-around I set save=lvl nestlvl=1 to filter out most of what I don't want, but this is still less than optimal. Am I missing something, or is this just a bug? Thanks! 

    • Post Points: 20
  • Thu, Sep 5 2013 9:35 PM

    Re: save option not working for ac within transient Reply

    It's a bug (I reported the issue a few years ago, CCR 772109). I thought it had not been fixed yet, but having re-checked, it's fixed in MMSIM12.1 (I tested in ISR12, so I'm not sure quite when it was fixed). It's definitely broken in MMSIM11.1, so it has been fixed relatively recently.

    Can you try MMSIM12.1 (you didn't say which version you're using)?

    Kind Regards,

    Andrew.

    • Post Points: 20
  • Fri, Sep 6 2013 6:51 AM

    Re: save option not working for ac within transient Reply

    Andrew,

    ->spectre -W
    sub-version  12.1.1.048

    • Post Points: 20
  • Fri, Sep 6 2013 8:13 AM

    Re: save option not working for ac within transient Reply

    Steve,

    I think this was fixed in that release - because I think the fix was in ISR8 which gave it enough time to make it into the update release (that's what you have). If it had been in ISR9, it probably wouldn't have made it in time (ISR9 is based on 12.1.0, rather than 12.1.1) - so you'd need at least ISR10 (which is based on 12.1.1 plus all the hotfixes from ISR9). So you could try using a more recent hotfix.

    However, before doing that, can you show me the analysis statements from the bottom of your input.scs (over one of the points in the monte carlo on the "Detail" view, do Right Mouse->VIew Netlist, and then cut and paste all the options/analysis statements at the bottom into this forum).

    Thanks,

    Andrew.

    • Post Points: 5
  • Fri, Sep 6 2013 1:44 PM

    Re: save option not working for ac within transient Reply

    Steve,

    I got my threads mixed up and was talking about a different issue. Let me check with that version.

    So ignore my previous append,I was talking about the issue with Monte Carlo and info times.

    I'll post once I've checked.

    Regards,

    Andrew

    • Post Points: 5
  • Fri, Sep 6 2013 2:18 PM

    Re: save option not working for ac within transient Reply

    OK, I tested this actimes issue with 12.1.1.048 and the problem still occurs there. WIth 12.1.1.096.isr12 it works fine. So it was fixed some time between the two, presumably. Anyway, if you use the latest ISR on downloads, you should be OK.

    Regards,

    Andrew.

    • Post Points: 5
Page 1 of 1 (6 items)
Sort Posts:
Started by Steve Mikes at 05 Sep 2013 10:15 AM. Topic has 5 replies.