Home > Community > Forums > Custom IC Design > Error while plotting Extracted simulation results

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Error while plotting Extracted simulation results 

Last post Thu, Sep 5 2013 7:01 AM by Andrew Beckett. 7 replies.
Started by aravindvj 04 Sep 2013 12:19 AM. Topic has 7 replies and 600 views
Page 1 of 1 (8 items)
Sort Posts:
  • Wed, Sep 4 2013 12:19 AM

    • aravindvj
    • Not Ranked
    • Joined on Thu, Mar 7 2013
    • Posts 8
    • Points 100
    Error while plotting Extracted simulation results Reply

    Hello

    While plottinhg results from transient simulation from extracted view, I am getting following error. Please advise a solution

    ERROR (WIA-1006): Unable to plot expression <VT("/I0/26274:gnd_ana" "/home/s1147823/UPVLC/cadenceAMS180A6/DAC/Sim/DAC_UPVLC/DAC_CELL_TB/adexl/results/data/Interactive.0/psf/DAC_UPVLC:DAC_CELL_TB:1")>

               because it does not evaluate to an object that can be plotted, like a waveform or

               parametric wave. See the Visualization & Analysis Tool documentation for information

               about the types of objects that can be plotted in Visualization & Analysis Tool. Only

               the expressions that evaluate to those objects can be plotted.

    *Warning* Wave1 is not a waveform object that can be displayed and

              will be DELETED automatically.

              name: "/I0/26274:gnd_ana"

    Thanks

    Aravind 

    • Post Points: 20
  • Wed, Sep 4 2013 3:35 AM

    Re: Error while plotting Extracted simulation results Reply

    Aravind,

    Did that signal get saved? Does it show up in the Results Browser?

    Regards,

    Andrew.

    • Post Points: 35
  • Wed, Sep 4 2013 4:42 AM

    • aravindvj
    • Not Ranked
    • Joined on Thu, Mar 7 2013
    • Posts 8
    • Points 100
    Re: Error while plotting Extracted simulation results Reply

    Hi Andrew

     

    Thanks for the reply

    I searched in the results browser. But the search did not return any matches for the specified net. I searched *4572* for the net /I0/4572:gnd_ana . In ADEXL test editor, I have set Outputs- Save all - Selected , since this is a large extracted netlist.

    Please advise

     

    Regards

    Aravind 

    • Post Points: 5
  • Wed, Sep 4 2013 4:45 AM

    • aravindvj
    • Not Ranked
    • Joined on Thu, Mar 7 2013
    • Posts 8
    • Points 100
    Re: Error while plotting Extracted simulation results Reply

    Hi Andrew

     

    Another point to add. Since /I0/4572:gnd_ana is from extracted view, I tried to plot it directly by Test Editor --> Outputs --> To be plotted --> Select on Schematic and then pointed to 4572:gnd_ana. 

    Also in ADEXL expressions, I used calculator to plot VT("/I0/4572:gnd_ana") , which was giving an eval error

     

    Regards

    Aravind 

    • Post Points: 20
  • Wed, Sep 4 2013 6:30 AM

    Re: Error while plotting Extracted simulation results Reply

    If it's not in the results browser, it didn't get saved. Does the signal appear in the "save" statements at the bottom of the netlist? Were there any warnings about it in the spectre log file?

    Regards,

    Andrew.

    • Post Points: 35
  • Wed, Sep 4 2013 7:09 AM

    • aravindvj
    • Not Ranked
    • Joined on Thu, Mar 7 2013
    • Posts 8
    • Points 100
    Re: Error while plotting Extracted simulation results Reply

    Hi Andrew

     It was there netlist (save section) as shown below

    save I0.\4572\:gnd_ana I0.\7049\:gnd_ana 

    saveOptions options save=selected 

    Thanks

    Aravind 

    • Post Points: 5
  • Wed, Sep 4 2013 7:22 AM

    • aravindvj
    • Not Ranked
    • Joined on Thu, Mar 7 2013
    • Posts 8
    • Points 100
    Re: Error while plotting Extracted simulation results Reply

    Hi Andrew

    I got following warnings in spectre log

        WARNING (SPECTRE-8281): `I0.4572\:gnd_ana' is not a node nor an instance name.

        WARNING (SPECTRE-8286): Ignoring invalid item `I0.4572\:gnd_ana' in save statement.

        WARNING (SPECTRE-8281): `I0.7049\:gnd_ana' is not a node nor an instance name.

        WARNING (SPECTRE-8286): Ignoring invalid item `I0.7049\:gnd_ana' in save statement. 

    It seems somehow the extracted node is not saved.

    Thanks

    Aravind 

    • Post Points: 20
  • Thu, Sep 5 2013 7:01 AM

    Re: Error while plotting Extracted simulation results Reply

    Does the net exist in the netlist?

    You might be best going to customer support with this - it's really difficult to debug without being able to see the data.

    Kind Regards,

    Andrew.

    • Post Points: 5
Page 1 of 1 (8 items)
Sort Posts:
Started by aravindvj at 04 Sep 2013 12:19 AM. Topic has 7 replies.