Home > Community > Forums > Custom IC Design > Have problem in simulating circuit in virtuoso ADE

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Have problem in simulating circuit in virtuoso ADE 

Last post Tue, Aug 27 2013 9:32 PM by Andrew Beckett. 3 replies.
Started by sunilreddy 27 Jul 2013 03:06 AM. Topic has 3 replies and 551 views
Page 1 of 1 (4 items)
Sort Posts:
  • Sat, Jul 27 2013 3:06 AM

    • sunilreddy
    • Not Ranked
    • Joined on Wed, Jun 26 2013
    • Singapore, 00-SG
    • Posts 4
    • Points 65
    Have problem in simulating circuit in virtuoso ADE Reply

    Hi 

    I generated a ideal adc from model writer option and then i created symbole for that.  I created a test bench for that model but when i simulate using virtuoso ADE i am getting error

    The error is in my verilog module i defined as a register dout<7:0> but when i created the netlist from the schematic it is taking individual bits so it is saying that undefined model can any one help how to get single wire name in the netlist for the wide bus 

    i am attaching the error message and schematic with this message  


    • Post Points: 20
  • Mon, Jul 29 2013 1:44 AM

    Re: Have problem in simulating circuit in virtuoso ADE Reply

    What is the exact error message? Can you post the VerilogA code too?

    Thanks,

    Andrew.

    • Post Points: 20
  • Fri, Aug 16 2013 4:09 AM

    • sunilreddy
    • Not Ranked
    • Joined on Wed, Jun 26 2013
    • Singapore, 00-SG
    • Posts 4
    • Points 65
    Re: Have problem in simulating circuit in virtuoso ADE Reply

    hai andrew

    it is verilog-AMS code

    and the error i got is same as  Problem while running verilog-ams block in cadence schematic editor started by indra

    http://www.cadence.com/Community/forums/p/26739/1325379.aspx#1325379 from that i got know that i need to setup AMS environment. i studied the user manual but i am unable to get it as i am new to linux and cadence so can you please elaborate me how to do the simulation with verilog-AMS code with schematic test bench.

     

    Regards

    Sunil  

    • Post Points: 20
  • Tue, Aug 27 2013 9:32 PM

    Re: Have problem in simulating circuit in virtuoso ADE Reply

    Sunil,

    I can't really give a complete tutorial here, especially when there is one in the software. Look at <ICinstDir>/doc/amsenvTutorials/amsenvTutorials.pdf

    In IC5141 this is in chapter 2 of <ICinstDir>/doc/amsenvug/amsenvug.pdf

    Regards,

    Andrew.

     

     

    • Post Points: 5
Page 1 of 1 (4 items)
Sort Posts:
Started by sunilreddy at 27 Jul 2013 03:06 AM. Topic has 3 replies.