Home > Community > Forums > Custom IC Design > Ultrasim is not recognising hspice (<) syntax

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Ultrasim is not recognising hspice (<) syntax 

Last post Tue, Jul 2 2013 2:56 AM by Andrew Beckett. 1 replies.
Started by Ankumar15 01 Jul 2013 03:39 PM. Topic has 1 replies and 413 views
Page 1 of 1 (2 items)
Sort Posts:
  • Mon, Jul 1 2013 3:39 PM

    • Ankumar15
    • Not Ranked
    • Joined on Thu, Feb 7 2013
    • Posts 2
    • Points 40
    Ultrasim is not recognising hspice (<) syntax Reply
    Hi ,

    I am running Ultrasim on hspice control file. I have following syntax in the hspice and Ultraspice does not like "?" . Error message says that "Unexpected ternary operator "?" .
    My hspice deck is

    .measure tran  v_out  find V(out) at=5n

    .measure result param='(V_out > 0.4)?1:0'

    Please let me know if you know how to resolve this issue.

     

    I am trying to validate  that whether V(out) is greater than 0.4V at 5ns , if yes then declare 1.  I have 10 bit to 1024 decoder and I am trying to make sure that circuit is deoding properly .

    If Ultrasim has similar function/syntax then it will be a great help.

    Thanks
    Anil K.
    Filed under:
    • Post Points: 20
  • Tue, Jul 2 2013 2:56 AM

    Re: Ultrasim is not recognising hspice (<) syntax Reply

    Anil,

    In this specific case, it would be sufficient just to use:

     .measure result param='(V_out > 0.4)'

    You might want to contact customer support to get the ternary operator supported in .MEASURE statements.

    Regards,

    Andrew.

    • Post Points: 5
Page 1 of 1 (2 items)
Sort Posts:
Started by Ankumar15 at 01 Jul 2013 03:39 PM. Topic has 1 replies.