Home > Community > Forums > Custom IC Design > "Error(s) found during netlisting. The netlist may be corrupt"

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 "Error(s) found during netlisting. The netlist may be corrupt" 

Last post Fri, May 31 2013 11:44 AM by NcfC. 4 replies.
Started by NcfC 30 May 2013 11:17 AM. Topic has 4 replies and 1408 views
Page 1 of 1 (5 items)
Sort Posts:
  • Thu, May 30 2013 11:17 AM

    • NcfC
    • Top 500 Contributor
    • Joined on Mon, Feb 27 2012
    • Chandler, AZ
    • Posts 28
    • Points 440
    "Error(s) found during netlisting. The netlist may be corrupt" Reply

    Hi,

    I'm using IC5.1.41 and everytime I start a new simulation, I get this error message. Even when the circuit has not been changed. One example is that, suppose I start an ADE session with design 1, which has been checked and saved (with no errors/warnings); run a simulation and then close the design. Now, if a choose to re-open design 1 and start a new ADE session and run the same previous simulation, I get the above mentioned error message.

    Does anyone has any idea on how to stop this message from appearing?

     On a related note, what options do I add to the ".cdsenv" file to stop ADE from quering to save the state and to stop CIW from quering to save the schematic when quiting?

     Thanks in advance. Best regards,

     

    Filed under: , ,
    • Post Points: 20
  • Thu, May 30 2013 11:23 AM

    • smlogan
    • Top 75 Contributor
    • Joined on Tue, Jun 10 2014
    • Posts 105
    • Points 1,800
    Re: "Error(s) found during netlisting. The netlist may be corrupt" Reply

     Often, this error is caused by a cell within your hierarchy that has changed in pinout. As a first try, do a Check->Hierarchy.

    If that does not work, traverse the hierarchy of the schematic and verify that all cells have been checked and saved.

     

    I do not know the answers to your other questions.

     

    Shawn

    • Post Points: 20
  • Thu, May 30 2013 11:48 AM

    • NcfC
    • Top 500 Contributor
    • Joined on Mon, Feb 27 2012
    • Chandler, AZ
    • Posts 28
    • Points 440
    Re: "Error(s) found during netlisting. The netlist may be corrupt" Reply
    Thanks for the reply, smlogan. But as I mentioned on the post, the schematic (and its hierarchy) had already been checked and saved, with no errors/warnings. So, it shouldn't report an error in netling. Reagrds,
    • Post Points: 20
  • Fri, May 31 2013 12:50 AM

    Re: "Error(s) found during netlisting. The netlist may be corrupt" Reply

    I would suggest that you open a case with customer support so that we can look at this with you. Whilst there are no more hotfixes for IC5141, maybe there is an explanation for why this is happening and we can give you a workaround - but seeing your data will almost certainly be needed.

    Kind Regards,

    Andrew.

    • Post Points: 20
  • Fri, May 31 2013 11:44 AM

    • NcfC
    • Top 500 Contributor
    • Joined on Mon, Feb 27 2012
    • Chandler, AZ
    • Posts 28
    • Points 440
    Re: "Error(s) found during netlisting. The netlist may be corrupt" Reply

    Thanks, Andrew.

     

    Regards. 

    • Post Points: 5
Page 1 of 1 (5 items)
Sort Posts:
Started by NcfC at 30 May 2013 11:17 AM. Topic has 4 replies.