Home > Community > Forums > Functional Verification > Create/Import Verilog-AMS Cell View

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Create/Import Verilog-AMS Cell View 

Last post Mon, May 27 2013 8:51 AM by Bayes. 0 replies.
Started by Bayes 27 May 2013 08:51 AM. Topic has 0 replies and 640 views
Page 1 of 1 (1 items)
Sort Posts:
  • Mon, May 27 2013 8:51 AM

    • Bayes
    • Not Ranked
    • Joined on Mon, May 27 2013
    • Posts 6
    • Points 75
    Create/Import Verilog-AMS Cell View Reply

    I have a problem with CADENCE, importing or creating a VERILOG-AMS file.

    I have to import a device model which has been developed in Verilog-AMS (I have a file with ".vams" extension).
    In the following, I try to summarize and explain what I have done and tried.

    1) I tried to import my file through the "IMPORT" tool of CADENCE but it seems to be impossible. I have this error: "The parser ncvlog failed to parse the text file. Refer to the file 'ncvlog.log' for compilation messages and errors". I don't know if the problem is related to the verilog editor/compiler named "ncvlog".

    2) I tried to use the tool "NC-VERILOG". Also in this case, when I try to generate the netlist from the "verilog-ams" file, I have the following error:"ERROR (OSSHNL-103): Unable to open the design, library 'GMR_Model', cell 'Test_2', view 'verilogams'. Ensure that the cell view exists or the SKILL variable, simDcmFilePath, is correctly defined".

     

    3) I tried to generate a new cell view creating a "Verilog-AMS" file with the "modelwriter" of Cadence or creating a "VerilogAMSText" utilizing a Verilog-AMS editor of Cadence.
    Once again I have problems because, in the first case, the ModelWriter of Cadence works fine but it is possible to create "verilog-ams" files only starting from a list of examples, without any possibility to change something. The generated example can be simulated with good results. On the contrary, when I try to generate a new "VerilogAMSText" utilizing a Verilog-AMS editor, a file "verilog-ams" is created, but not opened automatically with the editor. I have this warning: *WARNING* editFile: sh: xterm: command not found.

    I tried to set (manually) the editor for "verilog-ams" utilizing this command: "editor=<PATH of the editor>". I checked both "EXTERM" and "ncvlog". In the first case, setting: editor="/ic_tools/cds/IC.6.15.011/tools.lnx86/dracula/bin/32bit/EXTERM", when I try to generate a new file, the window of editor does not appears (probably the Editor doesn't work) and I have this error:/ic_tools/cds/IC.6.15.011/tools.lnx86/dracula/bin/32bit/EXTERM: error while loading shared libraries: libgdbm.so.2: cannot open shared object file: No such file or directory. In the second case, setting: editor="/ic_tools/cds/IC.6.15.011/tools.lnx86/inca/bin/ncvlog", when I try to generate a new file, the window of editor does not appears (probably the Editor doesn't work) and I have no errors. However, in both cases, a file "verilog-ams" is created in the "view" column and it is only possible to open it in "read-only" modality. In this case, the file is opened through a windows of VerilogAMS-Editor without any possibility to modify/edit the file and run the compiler VerilogAMS.

     

    Where is the problem? Is it related to Linux, the installation of CADENCE or other?

    How can I do to create a Verilog-AMS view and then simulate it?
    Thanks a lot.
    • Post Points: 5
Page 1 of 1 (1 items)
Sort Posts:
Started by Bayes at 27 May 2013 08:51 AM. Topic has 0 replies.