Home > Community > Forums > PCB Design > DRC does not check for Thru via to Thru via space of a same net

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 DRC does not check for Thru via to Thru via space of a same net 

Last post Sun, Apr 14 2013 3:06 PM by Kabal. 2 replies.
Started by Kabal 14 Apr 2013 02:35 PM. Topic has 2 replies and 551 views
Page 1 of 1 (3 items)
Sort Posts:
  • Sun, Apr 14 2013 2:35 PM

    • Kabal
    • Top 50 Contributor
    • Joined on Thu, Sep 29 2011
    • NM, NM
    • Posts 183
    • Points 2,530
    DRC does not check for Thru via to Thru via space of a same net Reply

    I have two vias of a same net, which i want to be apart at least 6 mils (I want DRC to check it Online as well).

     In the constaint manager for "Same Net Spacing", I check Thru Via To Thru Via to be 6 mil. 

    However, in the layout I still manage to place same net vias closer than 6 mils and DRC doesnt complain to that,

    even when I Update DRC through the Tools menu.

     

    Picture attached for clarity. Any ideas why is that happening?


    • Post Points: 20
  • Sun, Apr 14 2013 2:50 PM

    • KoryM
    • Not Ranked
    • Joined on Fri, Dec 3 2010
    • Posts 10
    • Points 95
    Re: DRC does not check for Thru via to Thru via space of a same net Reply

     One thing to check: in the Constraint Manager select the menu item Analyze > Analysis Modes....  On the left side of the window that pops up you should see Same Net Spacing Modes.  Check the appropriate box and then re-run DRC Update in the main window.

     

    Kory

    • Post Points: 5
  • Sun, Apr 14 2013 3:06 PM

    • Kabal
    • Top 50 Contributor
    • Joined on Thu, Sep 29 2011
    • NM, NM
    • Posts 183
    • Points 2,530
    Re: DRC does not check for Thru via to Thru via space of a same net Reply

     Ok,found it:

    Had to go to Constraints Manager-> Same Net Spacing->Options, and put TRUE for all layers. seems to be working now.

    • Post Points: 5
Page 1 of 1 (3 items)
Sort Posts:
Started by Kabal at 14 Apr 2013 02:35 PM. Topic has 2 replies.