Home > Community > Forums > Custom IC Design > No option of "Current" in Output Noise of noise analysis

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 No option of "Current" in Output Noise of noise analysis 

Last post Thu, Apr 11 2013 5:58 AM by RAO VINAY. 4 replies.
Started by RAO VINAY 11 Apr 2013 04:21 AM. Topic has 4 replies and 1060 views
Page 1 of 1 (5 items)
Sort Posts:
  • Thu, Apr 11 2013 4:21 AM

    • RAO VINAY
    • Top 500 Contributor
    • Joined on Tue, Feb 21 2012
    • Posts 19
    • Points 320
    No option of "Current" in Output Noise of noise analysis Reply

     Hello all,

                I tried to extract output noise current of a single MOS transistor. But in Analysis->noise, under "Output Noise" option row, it is showing only two option of "Voltage" and "Probe" but not "Current" as an option (figure is attached). How can I plot output noise current through noise analysis of ADE L? My versions are IC 614-06.14-512, Assura 4.1 USR2, MMSIM 0720.593 and EXT101. Thank you.

     

    Regards,

    Vinay Rao.

     


    • Post Points: 20
  • Thu, Apr 11 2013 4:49 AM

    Re: No option of "Current" in Output Noise of noise analysis Reply

    Hi Vinay,

    If you pick "Probe" the idea is that you then specify a device (e.g. a resistor or a voltage source) to measure the current through - and then the output noise will be a current.

    Regards,

    Andrew.

    • Post Points: 20
  • Thu, Apr 11 2013 5:20 AM

    • RAO VINAY
    • Top 500 Contributor
    • Joined on Tue, Feb 21 2012
    • Posts 19
    • Points 320
    Re: No option of "Current" in Output Noise of noise analysis Reply

     Thanks for your quick reply Andrew. I tried with the probe by selecting my MOS M0 in Output noise but when I plot "Squared Output Noise" under direct plot, values are shown in terms of V/sqrt(Hz) (figure is attached). Moreover it's not showing any option for plotting "Current" in "Main form (Results->Direct plot->Main form)". Also in the same figure, it's showing a downfall after around 10GHz and seems unreasonable.


    • Post Points: 20
  • Thu, Apr 11 2013 5:31 AM

    Re: No option of "Current" in Output Noise of noise analysis Reply

     Sorry, I was not clear enough. From "spectre -h noise" :

    The noise is computed at the output of the circuit. The output is specified with either a pair of
    nodes or a probe component. To specify the output of a circuit with a probe, specify it with the
    `oprobe' parameter. If the output is voltage (or potential), choose a `resistor' or a `port' as the
    output probe. If the output is current (or flow), choose a `vsource' or `iprobe' as the output probe.

    So you need to probe either a voltage source or an iprobe component - it will then measure the current flowing through that source or probe (the voltage source would probably be a zero-volt source).

    Regards,

    Andrew.

    • Post Points: 20
  • Thu, Apr 11 2013 5:58 AM

    • RAO VINAY
    • Top 500 Contributor
    • Joined on Tue, Feb 21 2012
    • Posts 19
    • Points 320
    Re: No option of "Current" in Output Noise of noise analysis Reply

     Thanks a lot Andrew. I used zero-volt source and now it works fine. 

     

    Regards,

    Vinay Rao.

     

     

    • Post Points: 5
Page 1 of 1 (5 items)
Sort Posts:
Started by RAO VINAY at 11 Apr 2013 04:21 AM. Topic has 4 replies.