Home > Community > Forums > Custom IC Design > How to correct for Turbo RuleFile warnings

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 How to correct for Turbo RuleFile warnings 

Last post Tue, Apr 2 2013 1:38 AM by RFStuff. 6 replies.
Started by RFStuff 27 Mar 2013 10:47 PM. Topic has 6 replies and 811 views
Page 1 of 1 (7 items)
Sort Posts:
  • Wed, Mar 27 2013 10:47 PM

    • RFStuff
    • Top 25 Contributor
    • Joined on Tue, Feb 5 2013
    • Posts 227
    • Points 3,995
    How to correct for Turbo RuleFile warnings Reply

    Dear All,

    I am using Turbo Tool Box in IC5141. I have created the Rulfilefor the foundry.

    However I am getting warnning each time I open TurboTollBox as below:-

    ! Missing minSpacing rule for CONT drawing and PO1 drawing value set to 0.0.

    Can anybody please tell:- Where I can change this value in the rule file ?

     

    Also I tried to modify the Rule file. I couldn't figure out where I should do the cahnge.

    Also when I try to enter the rules in TurboTool Form (Rule Files Utility) and save it, a form named /tmp/_leTbRules11270 comes up.

    Which also gives warning as:-


    ------------------------ MISSING PHYSICAL RULES -------------------------
    Some leTbRules are set to '0.0'. Toolbox commands may be affected if the
    required physical rules are not established first.
    _________________________________________________________________________

     

    Some of my TurboCommands are NOT functioning as well.

     

    Kind Regards,

     

    • Post Points: 20
  • Mon, Apr 1 2013 5:29 AM

    Re: How to correct for Turbo RuleFile warnings Reply

    Setting up Turbo toolbox rules is not something I've done for a rather long time, but I think the default values will be coming from the main Virtuoso tech file - it will be getting these from the two-layer spacing rules. This is done with a statement like:

    leTbRules->contact_to_ngate = _leTbGetTFRules( leTbRules->tfId "minSpacing" car( leTbRules->contact_layer ) car( leTbRules->ipoly_layer ) )
    leTbRules->contact_to_pgate = leTbRules->contact_to_ngate

    in the turbo toolbox rule file. 

    And in the tech file for your technology library, this would be in the spacingRules section within the physicalRules:

       ( minSpacing              "Poly"        "Cont"        0.1     )

    Regards,

    Andrew.

    • Post Points: 20
  • Mon, Apr 1 2013 6:59 AM

    • RFStuff
    • Top 25 Contributor
    • Joined on Tue, Feb 5 2013
    • Posts 227
    • Points 3,995
    Re: How to correct for Turbo RuleFile warnings Reply

     

    Dear Andrew,

    Thanks a lot.

    Actually, I could not exactly figure it out where I should change the 0.0 value to some non-zero value.

    In the Turbo rule files I saw,:-

      leTbRules->contact_to_pgate  = 0.0

       leTbRules->contact_to_ngate  = 0.0

    Shall I make them to non-zero value. Also there are may parameters having ZERO values.

    Kind Regards,

     

     

    • Post Points: 20
  • Mon, Apr 1 2013 6:39 PM

    • Quek
    • Top 10 Contributor
    • Joined on Wed, Oct 14 2009
    • Singapore, 00-SG
    • Posts 1,051
    • Points 15,990
    Re: How to correct for Turbo RuleFile warnings Reply

    Hi RFStuff

    For contact_to_gate, you can just set it to the min-spacing value between cont-to-poly if the value can be found in the foundry design rule manual (DRM). In general, you should be able to resolve all the zero value warnings by providing appropriate values for all the fields in the toolbox utility form. If you are just using the basic toolbox editing functions, then it is actually not necessary to resolve all the warnings (e.g. ignoring the warning for pwell_notch, etc) should be fine. : )

    In general, I think the toolbox should work fine if you provide the values for all the poly/metal interconnect layers.


    Best regards
    Quek

    • Post Points: 20
  • Mon, Apr 1 2013 7:10 PM

    • RFStuff
    • Top 25 Contributor
    • Joined on Tue, Feb 5 2013
    • Posts 227
    • Points 3,995
    Re: How to correct for Turbo RuleFile warnings Reply

     Dear Quek,

    Yes you are right. It is working fine even if the values are ZERO.

    However, when I am using some bindkeys with turbo Tool box on, the bind KEy doesn't work or icfb enters into a hang mode.

    It also gives warnning that since values  are ZERO soms command of Turbo will NOT work properly as I have mentioned earlier in this post.

    This  prompts me to suspect these ZERO warning stuffs.

    It looks like it is taking the bindKeys from the default "/local/samples/" location.

    How to make it take the bindKeys as normal Layout XL.

    Kind Regards,

    • Post Points: 20
  • Mon, Apr 1 2013 8:10 PM

    • Quek
    • Top 10 Contributor
    • Joined on Wed, Oct 14 2009
    • Singapore, 00-SG
    • Posts 1,051
    • Points 15,990
    Re: How to correct for Turbo RuleFile warnings Reply

    Hi RFStuff

    When starting the toolbox, you can choose not to enable toolbox bindkeys as shown in the form below. If you do not enable toolbox bindkeys, the Virtuoso bindkeys will be retained.

    Best regards
    Quek


    • Post Points: 20
  • Tue, Apr 2 2013 1:38 AM

    • RFStuff
    • Top 25 Contributor
    • Joined on Tue, Feb 5 2013
    • Posts 227
    • Points 3,995
    Re: How to correct for Turbo RuleFile warnings Reply

    Dear Quek,

    Thanks a lot.

    Now it is working like a charm.

    Kind Regards,

     

    • Post Points: 5
Page 1 of 1 (7 items)
Sort Posts:
Started by RFStuff at 27 Mar 2013 10:47 PM. Topic has 6 replies.