Home > Community > Forums > Custom IC SKILL > captab bind with monteCarlo

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 captab bind with monteCarlo 

Last post Sun, Mar 24 2013 4:45 AM by Andrew Beckett. 1 replies.
Started by imagesensor123 27 Feb 2013 04:56 AM. Topic has 1 replies and 768 views
Page 1 of 1 (2 items)
Sort Posts:
  • Wed, Feb 27 2013 4:56 AM

    captab bind with monteCarlo Reply

    Hello,

        did anybody try to get the capinfo during the monte carlo analysis? I have done a simulation from ADE, I can see the capacitance variation in spectre output file(logfile), there is a captab output in each iteration, but why I can just get the nominal simulation results when i perform a simulation from command "spectre input.scs" where I modify the info statement in the netlist ( capInfo info what=captab where=file file="%C:r.info.what" save=all threshold=0 detail=node sort=name), there is only the capacitance of the nominal transient simulation in the file "input.info.what" . where am i wrong?

     

    Regards, zfeng
    • Post Points: 20
  • Sun, Mar 24 2013 4:45 AM

    Re: captab bind with monteCarlo Reply

    The problem is that your info statement is not within the surrounding montecarlo analysis. You can't do that because there's no hook to do it. Even if you could, it would overwrite it at each point (you could use %A in the filename, and make sure you have "save family data" turned on, which would probably get around that).

    So I think you'll need to file an enhancement request, or run the simulation from spectre command line yourself with an edited netlist - or turn off all the analyses in ADE and put the analyses, including the monte carlo, in an include file.

    Regards,

    Andrew.

    • Post Points: 5
Page 1 of 1 (2 items)
Sort Posts:
Started by imagesensor123 at 27 Feb 2013 04:56 AM. Topic has 1 replies.