Home > Community > Forums > Custom IC Design > Ruler (bind-key 'k') not functioning as desired

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Ruler (bind-key 'k') not functioning as desired 

Last post Sun, Feb 24 2013 10:56 PM by Andrew Beckett. 3 replies.
Started by RFStuff 19 Feb 2013 10:58 AM. Topic has 3 replies and 886 views
Page 1 of 1 (4 items)
Sort Posts:
  • Tue, Feb 19 2013 10:58 AM

    • RFStuff
    • Top 25 Contributor
    • Joined on Tue, Feb 5 2013
    • Posts 249
    • Points 4,420
    Ruler (bind-key 'k') not functioning as desired Reply

    Dear All,

    It may be a silly question. But the issue is creating a lot of problem for me.

    I want to draw the ruler from 'x' point to 'y' point orthogonal.The ruler should begin at 'x' and end exactly at 'y'

    I draw the ruler like:-

                               1) Press button 'k'

                               2) Zoom in   ( hiZoomIn() ) to the desired point ( x) location by clicking Right Mouse Botton ( for getting the exacr point fine ZOOM-IN)

                               3) Then  press Left Mouse botton at point 'x'

                              4) Then I press Zoom-Out in the Tool Bar (Course Zoom-Out)

                             5)   Zoom in   ( hiZoomIn() ) to the desired point ( x) location by clicking Right Mouse Botton ( for getting the exacr point fine ZOOM-IN)   

                             6) Then  pressRight Mouse botton at point 'y'   

     

    This works fine for me. But at times I don't know what happens, while doing zoom-in using Mouse ( when I press Right Mouse botton) the Ruler gets marked.

    Then I have to close icfb ( IC5141) and restart it. Then things work fine.

    Could anybody please tell why it is happening so  and what should be done to avoid it.

    Kind Regads, 

     

     

    • Post Points: 5
  • Wed, Feb 20 2013 11:10 PM

    • RFStuff
    • Top 25 Contributor
    • Joined on Tue, Feb 5 2013
    • Posts 249
    • Points 4,420
    Re: Ruler (bind-key 'k') not functioning as desired Reply

    Just to add to it:-

    While this issue happens "

    In CIW I get warning as:-

     *WARNING* Cancelling function, exceeds nestability limit of 5.

    What it means ?? What is its cause ?

     

     

     

    • Post Points: 20
  • Sun, Feb 24 2013 5:43 PM

    • theopaone
    • Top 75 Contributor
    • Joined on Tue, Feb 12 2013
    • Cedar Park, TX
    • Posts 110
    • Points 1,650
    Re: Ruler (bind-key 'k') not functioning as desired Reply

     The warning is the key. You have more than 5 enterfunctions working at the same time and when you enter the zoom, you exceed the command stack. You are probably inside of an editing command such as move or stretch as well as the editing commands. Type ^C (ctrl C) a couple of times to make sure you have exited the functions, this may save you from having to restart Virtuoso.

    If this is something you do often, you may want to create a SKILL program that prompts you for the two zoom points, lets you enter the first point for the ruler, then zooms back out and prompts you for the next zoom points and then the last point for the ruler. Then it draws the ruler.

    If you wre using IC615, there is a built in snapping ruler. It snaps to edges/endpoints without having to zoom in.

    Ted

    • Post Points: 20
  • Sun, Feb 24 2013 10:56 PM

    Re: Ruler (bind-key 'k') not functioning as desired Reply
    Rather than using control-c you can just hit escape a few times to cancel out of nested functions. If you have multiple editor windows open within the same icfb, make sure you escape nested commands in all the windows - the nest limit is global, not per-window (if my recollection is correct). I think there was an issue in older versions where you could end up with uncancellable nested commands if you closed a window in the middle of a command (not sure if that was resolved by the version you're using)

    Finally you can increase the nest limit in options->user preferences in the CIW.

    Regards,
    Andrew.
    • Post Points: 5
Page 1 of 1 (4 items)
Sort Posts:
Started by RFStuff at 19 Feb 2013 10:58 AM. Topic has 3 replies.