Home > Community > Forums > PCB Design > Artwork created with warnings - What are they?

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Artwork created with warnings - What are they? 

Last post Tue, Feb 19 2013 5:12 AM by TH Designs. 9 replies.
Started by TH Designs 18 Feb 2013 05:35 AM. Topic has 9 replies and 1632 views
Page 1 of 1 (10 items)
Sort Posts:
  • Mon, Feb 18 2013 5:35 AM

    • TH Designs
    • Top 25 Contributor
    • Joined on Fri, Apr 13 2012
    • Warminster, PA
    • Posts 269
    • Points 4,370
    Artwork created with warnings - What are they? Reply

    I'm being told by a nice little box that my artwork has been created with warnings. When I look in the log file, sure enough, it says in the summary that certain layers had warnings but there are no little clues as to what they are and how to fix them.

    So......... How do I figure out what these warnings are?????

    I have generated artwork for other board files with no issues. This particular one has been fighting me every step.

    Tom

    • Post Points: 20
  • Mon, Feb 18 2013 6:24 AM

    • oldmouldy
    • Top 10 Contributor
    • Joined on Tue, Jul 15 2008
    • Woking, Surrey
    • Posts 1,371
    • Points 23,350
    Re: Artwork created with warnings - What are they? Reply
    The warning texts will definitely be in the file, check the Viewlog after Generate Artwork, or open photoplot.log in the board file directory, search for Warning, you will find them in the log.
    • Post Points: 35
  • Mon, Feb 18 2013 6:35 AM

    • TH Designs
    • Top 25 Contributor
    • Joined on Fri, Apr 13 2012
    • Warminster, PA
    • Posts 269
    • Points 4,370
    Re: Artwork created with warnings - What are they? Reply

    This is the summary from the photoplot.log file. Not very helpful.............

     SUMMARY:
            LAYER6 created with warnings
            LAYER7 created with warnings
            SPB created with warnings
            SPT created with warnings
            SSB created with warnings
            SST created with warnings
            SolderMask_Bot created with warnings
            SolderMask_Top created with warnings
            BOTTOM created with warnings
            LAYER5 created with warnings
            LAYER4 created with warnings
            LAYER3 created with warnings
            LAYER2 created with warnings
            TOP created with warnings

     ARTWORK had warnings

    • Post Points: 5
  • Mon, Feb 18 2013 6:37 AM

    • TH Designs
    • Top 25 Contributor
    • Joined on Fri, Apr 13 2012
    • Warminster, PA
    • Posts 269
    • Points 4,370
    Re: Artwork created with warnings - What are they? Reply

    Typical detailed output for each layer

    ================================================================
         PROCESSING FILM < LAYER7 >
         TO FILE < C:/allegro/LAYER7.art > ...
    ================================================================

      FILM PARAMETERS :
      ---------------------------------------------------------
      Undefined line width                8.00
      Mirror code                         NONE
      Rotate angle                        NONE
      Offset x:                           0.00
      Offset y:                           0.00
      Plot negative                       NO
      Suppress unconnected internal pads  NO
      Draw holes only                     NO

      APERTURES USED:
      ---------------------------------------------------------
      TYPE       SIZE/NAME                   ROT   MIRROR MODE
      ---------------------------------------------------------
      CIRCLE     0.00600                                  DARK
      CIRCLE     0.01800                                  DARK
      CIRCLE     0.02200                                  DARK
      CIRCLE     0.02800                                  DARK
      CIRCLE     0.05000                                  DARK
      CIRCLE     0.06500                                  DARK
      CIRCLE     0.07300                                  DARK
      CIRCLE     0.10000                                  DARK
      CIRCLE     0.40000                                  DARK
      SQUARE     0.05000                     0.000 NO     DARK
      SQUARE     0.07300                     0.000 NO     DARK

         LAYER7 created with warnings

    • Post Points: 20
  • Mon, Feb 18 2013 7:19 AM

    • steve
    • Top 10 Contributor
    • Joined on Fri, Jul 18 2008
    • Woking, Surrey
    • Posts 1,163
    • Points 18,900
    Re: Artwork created with warnings - What are they? Reply

    The default warning you normally see is related a photoplot outline (not really required) The warning is normally at the top of the log file and says something like:-

    ---- Photoplot outline rectangle not found ... using drawing extents

    • Post Points: 20
  • Mon, Feb 18 2013 7:34 AM

    • TH Designs
    • Top 25 Contributor
    • Joined on Fri, Apr 13 2012
    • Warminster, PA
    • Posts 269
    • Points 4,370
    Re: Artwork created with warnings - What are they? Reply

    Steve, there is a plot outline. In the begining of the log file it says it can't open a parameter file. Could this be causing the warnings?

     Can't open parameter file ... using default values:
         DEVICE-TYPE        GERBER6X00
         G-CODES            NO
         STATIONS-PER-WHEEL 24
         FILM-SIZE          24000 16000
         COORDINATES        ABSOLUTE
         OUTPUT-UNITS       INCHES
         FORMAT             5.3
         ABORT-ON-ERROR     abort film & continue
         SUPPRESS-LEAD-ZEROES     YES
         SUPPRESS-TRAIL-ZEROES    NO
         OPTIMIZE           YES
         SUPPRESS-EQUAL     YES
         SCALE              1.0

    • Post Points: 20
  • Mon, Feb 18 2013 7:44 AM

    • steve
    • Top 10 Contributor
    • Joined on Fri, Jul 18 2008
    • Woking, Surrey
    • Posts 1,163
    • Points 18,900
    Re: Artwork created with warnings - What are they? Reply

    Tom - I'd be suprised because if the parameter file (art_param.txt) isn;t found it writes a new one to the local job directory. Have you got any zero line widths? have you set the undefined line width per artwork film ? Do the output units = job units ? Are you sure you want to use 6X00 gerber rather than 274X ? Does the shape format = artwork format ?

    • Post Points: 20
  • Mon, Feb 18 2013 8:11 AM

    • TH Designs
    • Top 25 Contributor
    • Joined on Fri, Apr 13 2012
    • Warminster, PA
    • Posts 269
    • Points 4,370
    Re: Artwork created with warnings - What are they? Reply

    There is one zero width line on the top silk, but this board is to dense for the top silk so it will not be used. If this is causing the warnings, then why does it show as a warning on every layer.

    I will change to 274x.

    The first time I ran it, I had no warnings. I then went and added the pcb part number to the bottom silk and that is when the warnings started.

    I spent 20 hours on this job over the weekend, so by last night I was fried and didn't want to investigate too much. I was running the gerbers as a test, the board is going into review today so I have some time to sort it out. As usual, I'm sure it is something I'm doing incorrectly.........

    Tom

    • Post Points: 20
  • Mon, Feb 18 2013 4:01 PM

    • ScottCad
    • Top 50 Contributor
    • Joined on Sat, May 26 2012
    • Roswell, GA
    • Posts 176
    • Points 2,775
    Re: Artwork created with warnings - What are they? Reply

    Tom  suggest you always use RS274X when creating the gerbers. RS274X embeds all the info need into one file so as to do a photoplot. Pretty much all board-houses support RS274X.

    Also when you are setting up your gerber output, there is a field to define "Undefined Line width" for each film layer you want to output. By default this field is set to Zero and that should be fine most of the time, but as a safe-guard I typically make that field a "1"

    Normally Allegro is pretty darn good at scanning the design and generating dcodes for the shapes pads, lines etc using RS274X format, think if you use that format life will be easier for you.

    Scott

    • Post Points: 20
  • Tue, Feb 19 2013 5:12 AM

    • TH Designs
    • Top 25 Contributor
    • Joined on Fri, Apr 13 2012
    • Warminster, PA
    • Posts 269
    • Points 4,370
    Re: Artwork created with warnings - What are they? Reply
    ScottCad:

    Tom  suggest you always use RS274X when creating the gerbers. RS274X embeds all the info need into one file so as to do a photoplot. Pretty much all board-houses support RS274X.

    Also when you are setting up your gerber output, there is a field to define "Undefined Line width" for each film layer you want to output. By default this field is set to Zero and that should be fine most of the time, but as a safe-guard I typically make that field a "1"

    Normally Allegro is pretty darn good at scanning the design and generating dcodes for the shapes pads, lines etc using RS274X format, think if you use that format life will be easier for you.

    Scott

    Hi Scott,

    I always use 274x, in fact, I don't know why this one reported the other format because when I went back into the file, the default setting was 274x.

    For undefined line widths, I make the setting 8 for each layer.

    Something strange was happening when I was making those gerbers. Yesterday, I had a few small edits to do resulting from the design review. I made the changes then generated the gerbers using the same method I did on Sunday. This time I had no warnings or errors. I didn't change a thing other then add and route a few new capacitors.

    I have noticed another oddity. I need to document the steps to verify I can dupplicate it before submitting to tech. Let's say I'm in etch edit mode and routing. I then go and save the file (which I do fairly often). I then select F3 to continue routing, but I can not manually route anymore. I select etch edit, then add route and still can't route. I select placement edit, then etch edit, then add route and it is now working. It seems like after a save, I have to select a different mode then go back to the original mode and continue work. Again, I need to validate this, but I've seen it happen more then once.

    Tom

    • Post Points: 5
Page 1 of 1 (10 items)
Sort Posts:
Started by TH Designs at 18 Feb 2013 05:35 AM. Topic has 9 replies.