Home > Community > Forums > PCB Design > Issue updating symbols in PCB Editor

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Issue updating symbols in PCB Editor 

Last post Mon, Jan 14 2013 12:46 PM by oldmouldy. 1 replies.
Started by mvonahnen 14 Jan 2013 11:39 AM. Topic has 1 replies and 539 views
Page 1 of 1 (2 items)
Sort Posts:
  • Mon, Jan 14 2013 11:39 AM

    • mvonahnen
    • Top 50 Contributor
    • Joined on Wed, Aug 27 2008
    • Posts 131
    • Points 2,435
    Issue updating symbols in PCB Editor Reply

     I have an issue (version 16.5) where I had to upgrade a component and add a pin to it.  But the schematic netlisting function appears to ignore this, when I try to quick place the component I get: 

    "ERROR(SPMHGE-82): Pin numbers do not match between symbol and component. Run dev_check on device file for more information."

     From this issue and another one I found on the same BRD file, it appears once I have a symbol in the BRD database, I am unable to remove it.  If I rename the symbol to another name, it works fine and that is what I plan to do, but I do think this is a problem with the tool.  Is there a similar function for the BRD file that you can do for the schematic file where you "Clean up the Cache"?

    I noticed that if I have a mismatch between the symbol version in the Database and in the Library, the library component will not appear.  I don't know if this is supposed to happen, but it prevents me from manually upgrading my symbol.

     I have searched many of the other posts concerning similar problems and I tried several of the indicated suggestions, with no improvement.

    • Post Points: 20
  • Mon, Jan 14 2013 12:46 PM

    • oldmouldy
    • Top 10 Contributor
    • Joined on Tue, Jul 15 2008
    • Woking, Surrey
    • Posts 1,446
    • Points 24,595
    Re: Issue updating symbols in PCB Editor Reply

    Netlist driven flow - you need to get the netlist updated with the additional pin and then reload it, the changed symbol will be replaced in the board database, since it has changed, the component details will be unplaced. Yes, it's by design that you can't get anywhere with placing parts in the design or replacing component definitions if they don't match the netlist symbol defintion for the connect pins of the symbol.

    • Post Points: 5
Page 1 of 1 (2 items)
Sort Posts:
Started by mvonahnen at 14 Jan 2013 11:39 AM. Topic has 1 replies.