Home > Community > Forums > RF Design > No Insufficient Memory Promble in PSS/Pnoise simulation

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 No Insufficient Memory Promble in PSS/Pnoise simulation 

Last post Sat, Dec 29 2012 10:03 PM by Charley Hou. 2 replies.
Started by Charley Hou 27 Dec 2012 10:34 AM. Topic has 2 replies and 1165 views
Page 1 of 1 (3 items)
Sort Posts:
  • Thu, Dec 27 2012 10:34 AM

    No Insufficient Memory Promble in PSS/Pnoise simulation Reply

    Hi,

    I have some promblems on VCO Post-simulation of PSS and Pnoise. The Frequency of the VCO is 20GHz. When I simulate the schematic, everything is good. But when I comes to Post-simulation, there will always be the error "no insufficient memory".

    At first, I can't finish the pss and one of my classmates told me to set a swapfile. It's very useful and I can finished pss in about an hour. But now, I can finish the pnoise. 

    My parasitic resistor number is about 70,000. I try to run PEX with the output "C+CC", and the two simulation can finish quickly. So, is the parasitic resistor number is too much? Or there is something wrong in my setup.

    My setup is followed:

    -------------------------------------------------------------------------------------- 

    pss

    engine shooting

    Beatfrequency 18.46GHz(I have simulate transient to be sure of the oscillating frequency.)

    Number of harmonics 11

    Accuracy Defaults conservative

    tstab 40n(it is stable nearly 20ns.)

    Oscillator ON and OP

    Options

    swapfile set already

    method gear2only

    tstabmethod gear2only

    Pnoise

    sweeptype default relative harmonic 1

    frequency sweep range 10k 100M

      Points per Decade 10

    Maxmum sideband 11

    voltage ON OP

    ---------------------------------------------------------------------------------------

    And I also select "Run with 64 bit binary" in the Environment setup

     

     

    This problem has confused me for a long time, and I have googled it, but didn't find something helpful.

     I would appreciate it very much if anyone would help me with it.

    As I'm in UTC+8, so maybe I can't reply immediately.

     

     

    Filed under: , ,
    • Post Points: 20
  • Thu, Dec 27 2012 1:11 PM

    • Tawna
    • Top 25 Contributor
    • Joined on Thu, Jul 10 2008
    • Snohomish, WA
    • Posts 212
    • Points 5,625
    RE: No Insufficient Memory Promble in PSS/Pnoise simulation Reply
    Hi Charley,

    If this is a VCO like a ring oscillator (strongly nonlinear, sharp waveforms), use shooting engine with full spectrum pnoise.

    If a crystal oscillator or LC oscillator, use the harmonic balance engine.

    To speed things up, use APS. You can also set parasitic reduction (see spectre -h for more information). For example:
    spectre +aps +parasitics=rf input.scs

    best regards,
    Tawna
    Best regards, Tawna Wilsey Staff Support AE, Global Customer Support Cadence Design Systems, Inc.
    • Post Points: 20
  • Sat, Dec 29 2012 10:03 PM

    Re: RE: No Insufficient Memory Promble in PSS/Pnoise simulation Reply

    Hi Tawna,

      Thank you very much for your reply. The problem was solved.

    • Post Points: 5
Page 1 of 1 (3 items)
Sort Posts:
Started by Charley Hou at 27 Dec 2012 10:34 AM. Topic has 2 replies.