Home > Community > Forums > Custom IC Design > ADE XL and ocean scripts

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 ADE XL and ocean scripts 

Last post Mon, Dec 31 2012 4:34 AM by Andrew Beckett. 1 replies.
Started by radius2 27 Dec 2012 07:48 AM. Topic has 1 replies and 963 views
Page 1 of 1 (2 items)
Sort Posts:
  • Thu, Dec 27 2012 7:48 AM

    • radius2
    • Not Ranked
    • Joined on Thu, Dec 27 2012
    • Posts 1
    • Points 20
    ADE XL and ocean scripts Reply

    Hi,

    I'm trying to run simple ocean scripts from ADE XL in cadence IC 615. To begin with I only run a simple transient simulation. I specify the test under Tests in the data view and load a saved state from ADE L. Then running the simulation by using the run button works as it should. However, when I simply save the ocean script from ADE XL and then load it I get some problems.

    First, if the ADE XL window is open and the ocean script is loaded I get the following info and error:

     

    INFO (ADEXL-1642): The cell view "Library: test Cell: Invx4TB View: adexl2" is already open. It will not be opened in a new window

    *Error* There is no OCEAN XL session. Use ocnxlTargetCellView()

    command to create a session.

     

    If I look in the ocean script then I can see that the command ocnxlTargetCellView() was already generated when I saved the script from ADE XL so I don't understand why it is displaying this error message. 

     

    When I close the ADE XL window and run the script, i get problems with the model file i.e. the models for the transistors are undefined.

     

    Does anybody know if I'm doing something wrong or missing somehting or if it's another error? I'm a new beginner when it comes to ADE XL.

     

    Thanks.

    • Post Points: 20
  • Mon, Dec 31 2012 4:34 AM

    Re: ADE XL and ocean scripts Reply

    The idea is that when you run the OCEAN XL script, it will write all the simulation results into the ADE XL view as a history point, so that you can go to the Data assistant in ADE XL, switch to the history tab, and do RMB->View Results over your OCEAN history.

    In order to do that, it needs write access to the view - which it won't have if it's already open in ADE XL.

    The models being undefined presumably means that the setup hasn't defined where the models are located - maybe this wasn't setup in ADE XL before you saved the script?

    Andrew.

    • Post Points: 5
Page 1 of 1 (2 items)
Sort Posts:
Started by radius2 at 27 Dec 2012 07:48 AM. Topic has 1 replies.