Home > Community > Forums > Custom IC Design > Warning : (CMI-2826)

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Warning : (CMI-2826) 

Last post Thu, Dec 20 2012 3:35 AM by Andrew Beckett. 3 replies.
Started by reddy1553 20 Dec 2012 03:04 AM. Topic has 3 replies and 806 views
Page 1 of 1 (4 items)
Sort Posts:
  • Thu, Dec 20 2012 3:04 AM

    • reddy1553
    • Not Ranked
    • Joined on Thu, Dec 20 2012
    • Posts 4
    • Points 85
    Warning : (CMI-2826) Reply

    Hi,

    While I am running a simple resistor divider network through ADE, it is not working correctly.

    I am gettting the following warning :

    "WARNING (CMI-2826): R0_4__dmy0.rmain : No model and instance parameter is given."

    "WARNING (CMI-2826): R0_4__dmy0.rend : No model and instance parameter is given."

    Please help me on this.............

    Regards

    Deepak

    • Post Points: 20
  • Thu, Dec 20 2012 3:14 AM

    Re: Warning : (CMI-2826) Reply

    Deepak,

    My wild guess is that you don't have $CDS_Netlisting_Mode set to Analog. So try exiting virtuoso, and doing:

    setenv CDS_Netlisting_Mode Analog

    (or if using bash/ksh do "export CDS_Netlisting_Mode=Analog") 

    in the terminal and then restart virtuoso. Bring up ADE, and do a Simulation->Netlist->Recreate and see if that solves the problem.

    If it doesn't, please show the relevant portion of the netlist that it is complaining about.

    Regards,

    Andrew.

    • Post Points: 20
  • Thu, Dec 20 2012 3:29 AM

    • reddy1553
    • Not Ranked
    • Joined on Thu, Dec 20 2012
    • Posts 4
    • Points 85
    Re: Warning : (CMI-2826) Reply

    I set $CDS_Netlisting_Mode set to Analog.... and restarted

    But it is still showing the same problem...

    Netlist :

    // Cell name: test_r
    // View name: schematic
    //Series configuration of R1
    R1_1__dmy0  (net2 R1_1__dmy0 ) rppolywo l=10u w=2u m=1 mf=(1) \
            mismatchflag=0
    R1_2__dmy0  (R1_1__dmy0 R1_2__dmy0 ) rppolywo l=10u w=2u m=1 mf=(1) \
            mismatchflag=0
    R1_3__dmy0  (R1_2__dmy0 R1_3__dmy0 ) rppolywo l=10u w=2u m=1 mf=(1) \
            mismatchflag=0
    R1_4__dmy0  (R1_3__dmy0 net4 ) rppolywo l=10u w=2u m=1 mf=(1) \
            mismatchflag=0
    //End of R1

    //Series configuration of R0
    R0_1__dmy0  (net4 R0_1__dmy0 ) rppolywo l=10u w=2u m=1 mf=(1) \
            mismatchflag=0
    R0_2__dmy0  (R0_1__dmy0 R0_2__dmy0 ) rppolywo l=10u w=2u m=1 mf=(1) \
            mismatchflag=0
    R0_3__dmy0  (R0_2__dmy0 R0_3__dmy0 ) rppolywo l=10u w=2u m=1 mf=(1) \
            mismatchflag=0
    R0_4__dmy0  (R0_3__dmy0 0 ) rppolywo l=10u w=2u m=1 mf=(1) mismatchflag=0
    //End of R0

    Log file Warnings :

    Warning from spectre during initial setup.
        WARNING (CMI-2826): R0_4__dmy0.rmain:  No model and instance parameter is given.
        WARNING (CMI-2826): R0_4__dmy0.rend:  No model and instance parameter is given.
        WARNING (CMI-2826): R0_3__dmy0.rmain:  No model and instance parameter is given.
        WARNING (CMI-2826): R0_3__dmy0.rend:  No model and instance parameter is given.
        WARNING (CMI-2826): R0_2__dmy0.rmain:  No model and instance parameter is given.
            Further occurrences of this warning will be suppressed.
    Notice from spectre during topology check.
        No DC path from node `R1_1__dmy0' to ground, Gmin installed to provide path.
        No DC path from node `R1_2__dmy0' to ground, Gmin installed to provide path.
        No DC path from node `R1_3__dmy0' to ground, Gmin installed to provide path.
        No DC path from node `net4' to ground, Gmin installed to provide path.
        No DC path from node `R0_1__dmy0' to ground, Gmin installed to provide path.
            Further occurrences of this notice will be suppressed.

    • Post Points: 20
  • Thu, Dec 20 2012 3:35 AM

    Re: Warning : (CMI-2826) Reply

    Actually the rppolywo definition should be in the model files from your foundry (TSMC at a guess) and so would be unaffected by the netlisting. It suggests that something is wrong with the model files you're using - you could take a look at the definition of rppolywo in your model files to see if that sheds any light (you can't post it here because it's TSMC IP). Otherwise you may have to contact TSMC - or contact customer support so that we can talk you through what to look at over the phone (say).

    Regards,

    Andrew.

     

    • Post Points: 5
Page 1 of 1 (4 items)
Sort Posts:
Started by reddy1553 at 20 Dec 2012 03:04 AM. Topic has 3 replies.