Home > Community > Forums > PCB Design > Problem highlighting part

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Problem highlighting part 

Last post Fri, Nov 30 2012 7:34 AM by SteveJD. 4 replies.
Started by SteveJD 29 Nov 2012 02:34 PM. Topic has 4 replies and 920 views
Page 1 of 1 (5 items)
Sort Posts:
  • Thu, Nov 29 2012 2:34 PM

    • SteveJD
    • Not Ranked
    • Joined on Thu, Nov 29 2012
    • Posts 2
    • Points 25
    Problem highlighting part Reply

    We recently  did our first design using Allegro version 16.5 and I am having problems highlighting parts when using the viewer of the same version. 

     In the past I could zoom in anywhere on the PCB, click the "I" icon then use find to locate the part by refdes and the highlighted part  would  jump to the middle of the display. 

    With the new version this does not happen. What is does now is zoom out so you can't find the part.   I can open 16.3 PCBs in the 16.5 viewer and it works like I just described above where the part jumps to the center screen with no change in zoom.  Has anybody else seen this behaviour? 

    I'm just the guy trying to debug PCBs in the engineering lab and this is one of the most important features I use and now it's broke....

    I showed our PCB designer and she did not know how to make it work either. 

    • Post Points: 20
  • Thu, Nov 29 2012 3:31 PM

    Re: Problem highlighting part Reply

    I'm still on 16.3 so I'm not sure but this might be what you are looking for.

    http://www.cadence.com/Community/forums/t/23167.aspx?PageIndex=1

     

    • Post Points: 35
  • Fri, Nov 30 2012 5:09 AM

    • budnoel
    • Top 50 Contributor
    • Joined on Tue, Aug 12 2008
    • Rochester, NY
    • Posts 129
    • Points 2,100
    Re: Problem highlighting part Reply

    I've just tried doing exactly as you have described and it appears to work correctly.  I'm using the 16.5 physical viewer and performing the following steps:

    1. Turned all subclasses off except Pkg_geom - Place bound top and bottom and Pin - Top and bottom

    2. Ensured I have no other active commands and zoomed in to an arbitrarily small area anywhere on the board.  (This might be the important step you are missing) 

    3. Selected the "I" icon (information)

    4. Selected Find - Symbols only

    5. Using "Find By Name" selected "Symbol (or Pin)"

    6. Clicked "More" to open the "Find by Name or Property" menu. 

    7. Arbitrarily selected a component from the list of refdes on the left and observed it being added to the "Selected objects" list on the right. 

    8. Clicked "Ok" and observed my screen automatically zoom and highlight the selected component.

    Let me know how you make out.

    • Post Points: 20
  • Fri, Nov 30 2012 5:36 AM

    • TH Designs
    • Top 25 Contributor
    • Joined on Fri, Apr 13 2012
    • Warminster, PA
    • Posts 269
    • Points 4,370
    Re: Problem highlighting part Reply
    Mstrghettorigg:

    I'm still on 16.3 so I'm not sure but this might be what you are looking for.

    http://www.cadence.com/Community/forums/t/23167.aspx?PageIndex=1

    Add the commands shown in this above mentioned link and then you can use "ctrl-f" which will bring up a pop-up bux where you can enter the reference you are looking for. It works well.

    I ran into this issue a while back and started that thread. It is a very good thread if your designer has the time to read through it all. Lots of good info in it.

    Tom

    • Post Points: 5
  • Fri, Nov 30 2012 7:34 AM

    • SteveJD
    • Not Ranked
    • Joined on Thu, Nov 29 2012
    • Posts 2
    • Points 25
    Re: Problem highlighting part Reply

     Thanks for the reply.  I gave it a try and it did the same thing.  I normally do this when zoomed in and it usually keeps the zoom I have or zooms in closer. 

     I'm going to read thru the find thread and see what I can learn from that.  I also forwarded it to our designer.   I can't work on this full time so it might take me awhile to figure it out...

     

    UPDATE:  I was chatting with one of our EEs and he showed me a different way to zoom to the part that works in 16.5! 

    Click on the "i" icon, click on the find tab, select symbol in the Design Object Find Filter, select symbol in the FindByName, type the refdes in the FindByName entry box and hit return.  The show element dialog box will pop up.  Click on the origin-xy number.  That will center the refdes on the screen.  Click on the zoom icon until the part is displayed to your desired size.

    Alternately you can type "symbol refdes" on the command line and it will open up show element dialog.  Then clik on the origin-xy number to center the part and zoom as needed.

    • Post Points: 5
Page 1 of 1 (5 items)
Sort Posts:
Started by SteveJD at 29 Nov 2012 02:34 PM. Topic has 4 replies.