Home > Community > Forums > PCB Design > Intertool communications

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Intertool communications 

Last post Wed, Nov 21 2012 10:43 AM by TH Designs. 7 replies.
Started by TH Designs 20 Nov 2012 11:42 AM. Topic has 7 replies and 1400 views
Page 1 of 1 (8 items)
Sort Posts:
  • Tue, Nov 20 2012 11:42 AM

    • TH Designs
    • Top 25 Contributor
    • Joined on Fri, Apr 13 2012
    • Warminster, PA
    • Posts 269
    • Points 4,370
    Intertool communications Reply

    When I pick a part in editor, it does not highlight in Capture. I have intertool comm enabled, I have opened and closed editor and capture and regenerated the netlist.

    I'm expecting that when I move R1 in Editor, R1 will highlight in Capture.......... right?

    I have witnessed placing parts from Capture also. If I do a series of key clicks between Editor and Capture on an open area in editor and a part in Capture (I have yet to figure out the exact series because it keeps changing) then I can highlight a part from capture, but still need to click on it to place it in editor.

    Here is what I'm looking for, when I select a part to place or move in Editor, I would like the corresponding part to be selected in Capture.

    I would also like to be able to click on a part in Capture and the corresponding part be attached to my cursor in Editor.

    What am I doing wrong...........

     Thanks,

     Tom

    • Post Points: 35
  • Tue, Nov 20 2012 11:49 AM

    • Roger BFS
    • Top 100 Contributor
    • Joined on Fri, Mar 4 2011
    • Morrison, CO
    • Posts 67
    • Points 965
    Re: Intertool communications Reply

    Tom,

    What I have discovered for the intertool stuff to work like you are expecting, the Capture window and the PCB editor window both have to be open and tiled (side-by-side, etc) on your screen.  Windows behind one another or minimized don't seem to work quiet right or consistently anyway.

    Roger

    Roger Green - B F Systems, LLC
    • Post Points: 20
  • Tue, Nov 20 2012 11:50 AM

    • budnoel
    • Top 50 Contributor
    • Joined on Tue, Aug 12 2008
    • Rochester, NY
    • Posts 129
    • Points 2,100
    Re: Intertool communications Reply

    I believe you need to "Highlight" the component in Editor.  What I've also found that works pretty well for me is if I first select the "Move" command in editor, then go to the schematic and select the component, that component is automatically attached to the my cursor in editor and ready for placement.  I toggle the "Previous Zoom" level to immediately return to the area of the design that I had previously been focusing on.  Also, you have to make sure that you don't have anything highlighted or selected before you begin any of the sequences.  I hope this helps.  It took me a little getting used to so don't get discouraged.

    • Post Points: 20
  • Tue, Nov 20 2012 12:00 PM

    • TH Designs
    • Top 25 Contributor
    • Joined on Fri, Apr 13 2012
    • Warminster, PA
    • Posts 269
    • Points 4,370
    Re: Intertool communications Reply

    Hi Roger,

    I use two monitors, one for Capture and one for Editor. So both environments are open at the same time.

    Tom

    • Post Points: 20
  • Tue, Nov 20 2012 12:07 PM

    • Roger BFS
    • Top 100 Contributor
    • Joined on Fri, Mar 4 2011
    • Morrison, CO
    • Posts 67
    • Points 965
    Re: Intertool communications Reply

    Although not currently, I have used dual monitors as well.  But depending on your graphics card, video setup, I don't think that always counts to the Cadence tools <grin>.  Perhaps there's another little openGL/Win7 "feature" to contend with - - -

    Good luck.

    Roger

    Roger Green - B F Systems, LLC
    • Post Points: 5
  • Tue, Nov 20 2012 12:11 PM

    • TH Designs
    • Top 25 Contributor
    • Joined on Fri, Apr 13 2012
    • Warminster, PA
    • Posts 269
    • Points 4,370
    Re: Intertool communications Reply

    budnoel:

    What I've also found that works pretty well for me is if I first select the "Move" command in editor, then go to the schematic and select the component, that component is automatically attached to the my cursor in editor and ready for placement.  I toggle the "Previous Zoom" level to immediately return to the area of the design that I had previously been focusing on.  

    Wow, it worked the first try!

    But............... Now I can't get it to work again!. Once and done I suppose............

    Since It worked once, some mode or setting must have changed to prevent it from working again. I'll have to hunt around a bit more.

    Thanks,

    Tom

    • Post Points: 20
  • Wed, Nov 21 2012 1:32 AM

    • steve
    • Top 10 Contributor
    • Joined on Fri, Jul 18 2008
    • Woking, Surrey
    • Posts 1,054
    • Points 16,990
    Re: Intertool communications Reply

     

    There are a few options:-

    You MUST have intertool communication enabled in Capture. After this you need t re-create and import your netlist into PCB Editor. Once done you can LMB (left mouse button) any part in Capture and it will highlight in the PCB (It should zoom to it as well). If you want to go from PCB To Capture then you need to invoke a command like Highlight or Assign Color then pick the part and it will highlight in the schematic. You will need to use the Dehighlight command to dehighlight the parts in PCB Editor. To Place from the Capture window invoke the command Place - Manually in PCB Editor then click on the Hide button in the GUI, then single LMB the part in Capture and move your mouse (do not drag) to the PCB Editor window and the part will be attached and ready to place.

    • Post Points: 20
  • Wed, Nov 21 2012 10:43 AM

    • TH Designs
    • Top 25 Contributor
    • Joined on Fri, Apr 13 2012
    • Warminster, PA
    • Posts 269
    • Points 4,370
    Re: Intertool communications Reply
    steve:

    To Place from the Capture window invoke the command Place - Manually in PCB Editor then click on the Hide button in the GUI, then single LMB the part in Capture and move your mouse (do not drag) to the PCB Editor window and the part will be attached and ready to place.

    Hi Steve,

    This is very useful. Thank you.

    I was hoping I could just select the part to move in pcb and it would highlight in the schematic (the way it did in 16.2 and previous), but it no longer works that way. I had several emails back and forth with Cadence tech support and it looks like the "old" way has gone bye, bye.

    I relied on being able to click on a part as I was doing placement and seeing it in the schematic. This would allow me to place the parts in a much more effecient way, both time wise and electrically. Doing it your way, from the schematic is very similar and I do believe I can use it in place of the "old way".

    Tom

    • Post Points: 5
Page 1 of 1 (8 items)
Sort Posts:
Started by TH Designs at 20 Nov 2012 11:42 AM. Topic has 7 replies.