Home > Community > Forums > Custom IC Design > veriloga model not being found

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 veriloga model not being found 

Last post Wed, Nov 14 2012 11:07 AM by TonySal. 2 replies.
Started by kristen 05 Oct 2012 08:28 AM. Topic has 2 replies and 1031 views
Page 1 of 1 (3 items)
Sort Posts:
  • Fri, Oct 5 2012 8:28 AM

    • kristen
    • Top 500 Contributor
    • Joined on Wed, Nov 3 2010
    • Posts 18
    • Points 345
    veriloga model not being found Reply

    Hi,

     I'm trying to instantiate this veriloga FET model http://ptm.asu.edu/postsi.html and i followed the instructions in the pdf to instantiate as a symbol. now when i try to run a simulation, I see the error:

    ERROR (OSSHNL-116): Unable to descend into any of the views defined in the view list, 'veriloga spectre cmos_sch cmos.sch schematic' for the instance 'I5' in cell 'tb_dc'. Either add one of these views to the library 'cntfet_sim', cell 'CNTfet' or modify the view list to contain an existing view.

      I can manually descend into both the symbol and veriloga cellviews from the testbench, so I'm not sure what the issue is. All the forum posts I've seen seem to have solved the issue by adding 'veriloga' to both the switch view and stop view lists, which I have done - the software is just not seeing it. 

     can anyone help? I'm sure it's a simple fix as I have no experience using veriloga in cadence before. 

      

    • Post Points: 20
  • Tue, Oct 9 2012 12:23 PM

    • kristen
    • Top 500 Contributor
    • Joined on Wed, Nov 3 2010
    • Posts 18
    • Points 345
    Re: veriloga model not being found Reply
    Does anyone have any suggestions? I implemented all the suggestions in this thread but no luck: http://www.edaboard.com/thread267995.html
    • Post Points: 5
  • Wed, Nov 14 2012 11:07 AM

    • TonySal
    • Not Ranked
    • Joined on Fri, Oct 24 2008
    • Fremont, CA
    • Posts 5
    • Points 85
    Re: veriloga model not being found Reply

    Based on the error message, you are using the cell name "CNTfet".

    In the veriloga code, did you change the module name to "CNTfet" ?

    Good luck,

    Tony

    • Post Points: 5
Page 1 of 1 (3 items)
Sort Posts:
Started by kristen at 05 Oct 2012 08:28 AM. Topic has 2 replies.