Home > Community > Forums > PCB Design > Skill loading problem

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Skill loading problem 

Last post Mon, Jun 23 2014 8:31 AM by Prasanthkv33. 5 replies.
Started by priya05 24 Sep 2012 03:14 AM. Topic has 5 replies and 1781 views
Page 1 of 1 (6 items)
Sort Posts:
  • Mon, Sep 24 2012 3:14 AM

    • priya05
    • Top 500 Contributor
    • Joined on Thu, Mar 22 2012
    • karur, Tamil Nadu
    • Posts 21
    • Points 445
    Skill loading problem Reply

    While loading skill in the orcad pcb designer,i m getting the following error.

    "Command not found:skill  "

     all the skills are placed in the below folder

    C:\xxxxx\xxx\share\pcb\etc\skill 

    Please see my allegro.ilinit file.

    Any wrong in this  

    regards, priya.
    • Post Points: 35
  • Mon, Sep 24 2012 3:51 AM

    • steve
    • Top 10 Contributor
    • Joined on Fri, Jul 18 2008
    • Woking, Surrey
    • Posts 1,172
    • Points 18,990
    Re: Skill loading problem Reply

    Please use the following exe to setup the allegro.ilinit file. Run the exe, specify the directory where all your skill files are and it creates the allegro.ilinit file correctly.http://www.parallel-systems.co.uk/downloads/ConfigureLocalSkillLocation.zip

    • Post Points: 20
  • Mon, Sep 24 2012 5:01 AM

    • priya05
    • Top 500 Contributor
    • Joined on Thu, Mar 22 2012
    • karur, Tamil Nadu
    • Posts 21
    • Points 445
    Re: Skill loading problem Reply

    I have downloaded that .exe file it automatically generate allegro.ilinit file.still i m getting the same error in the commnad window.

    Command not found:skill 

    regards, priya.
    • Post Points: 35
  • Mon, Sep 24 2012 6:04 AM

    • fxffxf
    • Top 25 Contributor
    • Joined on Thu, Jul 17 2008
    • ., AK
    • Posts 291
    • Points 4,640
    Re: Skill loading problem Reply

    You don't indicate when you see this message. I would check the following:

    - The Skill cmd is in a custom menu file ( allegro.men )  look for the "skill" command if that file. 

    - Check any modied env files for the skill command associated with the alias or funckey definitions.

    Once you find the skill command, you need to utilize the axlCmdRegister Skill function to register a new Allegro command for the function in question. The  Skill function is the argument to the skill command. Example if you see "skill AcmeCmd"  the skill function is AcmeCmd.

    To find the skill file (.il) that defines tjhe Skill function (one of files in allegro.ilinit) search your skill files (<>.il).

    Open the file and you can either see:

    - if a axlCmdRegister already exists 

    - if it doesn't exist add one -- general format: axlCmdRegister("my_allegro_command" "AcmeCmd")

    Now go back to the location you found the skill cmd and replace it with the Allegro command you defined via axlCmdRegister. Example if you had:

       skill AcmeCmd

    It would become:

       my_allegro_command

    • Post Points: 5
  • Mon, Sep 24 2012 6:56 AM

    • steve
    • Top 10 Contributor
    • Joined on Fri, Jul 18 2008
    • Woking, Surrey
    • Posts 1,172
    • Points 18,990
    Re: Skill loading problem Reply

    What the allegro.ilinit file does it to autoload all the skill files in the specified directory. Once inside Allegro the skill is already loaded so you just need to type the comand to run the skill. For example Logomaker.il would need logomaker typed in the Allegro command line.

    • Post Points: 5
  • Mon, Jun 23 2014 8:31 AM

    Re: Skill loading problem Reply

    Yes,

    the load commad is wrong

    instead of

    load("solder_paste.il") 

    just give

    load "solder_paste.il"

    in the allegro.ilinit file.

    it will load the il file, "solder_paste"

    Regards

    Prasanth.kv 

    • Post Points: 5
Page 1 of 1 (6 items)
Sort Posts:
Started by priya05 at 24 Sep 2012 03:14 AM. Topic has 5 replies.