Home > Community > Forums > Custom IC Design > icfb (Ver. 5.1.0) failed to start with openLDAP authentication enabled

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 icfb (Ver. 5.1.0) failed to start with openLDAP authentication enabled 

Last post Thu, Nov 28 2013 4:41 PM by Ducatte. 5 replies.
Started by rfvlsilab 11 Sep 2012 05:49 AM. Topic has 5 replies and 2300 views
Page 1 of 1 (6 items)
Sort Posts:
  • Tue, Sep 11 2012 5:49 AM

    • rfvlsilab
    • Not Ranked
    • Joined on Tue, Sep 11 2012
    • Hsinchu, 00-TW
    • Posts 3
    • Points 60
    icfb (Ver. 5.1.0) failed to start with openLDAP authentication enabled Reply

    Hello Folks,

    Does anyone who uses openLDAP to manage login credentials?

    My setup is icfb 5.1.0 @(#)$CDS: icfb.exe version 5.1.0 10/28/2008 10:23 (cicln03) $ the user account is authenticated by ldap.

    when I tried to start icfb, the following message appears:

      *WARNING* voInit failed to find the passwd entry for (null), using '/tmp' for a home directory.
    The most likely cause of this problem is the failure of NIS lookups.
    Please contact your system administrator.
    *WARNING* clsInit failed: Success
    *WARNING* file /home/<my_account>/CDS.log Success
    *WARNING* file /home/
    <my_account>/CDS.log.1 Success
    *WARNING* file /home/
    <my_account>/CDS.log.2 Success
    *WARNING* file /home/
    <my_account>/CDS.log.3 Success
    *WARNING* file /home/
    <my_account>/CDS.log.4 Success
    *WARNING* file /home/
    <my_account>/CDS.log.5 Success
    *WARNING* file /home/
    <my_account>/CDS.log.6 Success
    *WARNING* file /home/
    <my_account>/CDS.log.7 Success
    *WARNING* file /home/
    <my_account>/CDS.log.8 Success
    *WARNING* file /home/
    <my_account>/CDS.log.9 Success
    Failed to lock log file: /home/
    <my_account>/CDS.log.9

    does anyone has any solutions to this? Thanks in advance.

     BTW, I've a newer version of virtuoso installed (IC6.1.4) which operates without any problem.

     

    Michael

    • Post Points: 20
  • Tue, Sep 11 2012 6:13 AM

    Re: icfb (Ver. 5.1.0) failed to start with openLDAP authentication enabled Reply

    Michael,

    There have been some similar problems reported before (although none mention openLDAP). For example this solution. I found another which talked about needing to recompile openssh on the RHEL version being used.

    I'd say that the first thing you should try is using the latest IC5141 hotfix (you're using quite an old build there), and if that doesn't work, contact customer support so that we can try to resolve your machine setup so that this works.

    Regards,

    Andrew.

    • Post Points: 20
  • Tue, Sep 11 2012 6:43 AM

    • rfvlsilab
    • Not Ranked
    • Joined on Tue, Sep 11 2012
    • Hsinchu, 00-TW
    • Posts 3
    • Points 60
    Re: icfb (Ver. 5.1.0) failed to start with openLDAP authentication enabled Reply

    Hello, Andrew

     Our license is sub-leased from an institution called CIC in Taiwan, so I'm unable to directly register for Cadence online support, could you please send me a copy of the solution you mentioned? My email is michael@rfvlsi.ee.nctu.edu.tw

    Thank you

    • Post Points: 20
  • Tue, Sep 11 2012 6:58 AM

    Re: icfb (Ver. 5.1.0) failed to start with openLDAP authentication enabled Reply
    The solution is talking about if you're using winbind, and it tells you how to alter things in winbind to make it work. So it's probably not relevant. It just says:

    The problem is related to the fact that winbind is being used as name service. The related part in   /etc/nsswitch.conf   is:

    passwd:     files winbind
    shadow:     files winbind
    group:      files winbind

    This also explains why the problem does not exist for local users.

    The solution is to go to the Winbind Authentication Configuration and  then in the Options tab turn on the following two flags:

    Cache User Information

    Use Shadow Passwords
    • Post Points: 5
  • Tue, Sep 11 2012 11:41 PM

    • rfvlsilab
    • Not Ranked
    • Joined on Tue, Sep 11 2012
    • Hsinchu, 00-TW
    • Posts 3
    • Points 60
    Re: icfb (Ver. 5.1.0) failed to start with openLDAP authentication enabled Reply

    To workaround,

    add entries for LDAP users into /etc/passwd, and everything works fine. Make sure uid/gid/home/login shell are identical to ldap

    (do not add /etc/shadow entries)

    Michael

    • Post Points: 20
  • Thu, Nov 28 2013 4:41 PM

    • Ducatte
    • Not Ranked
    • Joined on Sun, Jun 17 2012
    • Posts 3
    • Points 45
    Re: icfb (Ver. 5.1.0) failed to start with openLDAP authentication enabled Reply

     Hi Michael,

     Could you please explain me better this workaround of how can I find the list of LDAP users to add in /etc/passwd ?

     Kind Regards,


     

    • Post Points: 5
Page 1 of 1 (6 items)
Sort Posts:
Started by rfvlsilab at 11 Sep 2012 05:49 AM. Topic has 5 replies.