Home > Community > Forums > Digital Implementation > globalNetConnect fails due to pin and net polarity

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 globalNetConnect fails due to pin and net polarity 

Last post Fri, Nov 16 2012 1:31 AM by HSpeek. 1 replies.
Started by mizzihood 20 Aug 2012 06:07 AM. Topic has 1 replies and 1337 views
Page 1 of 1 (2 items)
Sort Posts:
  • Mon, Aug 20 2012 6:07 AM

    • mizzihood
    • Not Ranked
    • Joined on Fri, Aug 17 2012
    • Posts 4
    • Points 80
    globalNetConnect fails due to pin and net polarity Reply

    Hello!

     I'm trying to connect vdd and vss nets to instance pins and the command
    > globalNetConnect vdd_net -type pgpin   -pin VDD_pin -inst instance_name -verbose 
    executes as expected and creates the connection. However, the command for vss connection
    globalNetConnect vss_net -type pgpin   -pin VSS_pin -inst instance_name -verbose 
    returns the following message:
    **ERROR: (ECNDB-1220): A global net connection rule for connection 'VSS_pin' of cell '...' to a global net '...' was specified. But the connection can not be made because the pin and the global net are not of the same polarity. Check the rule, and correct the issue. 

    I have examined the lef file of the instance to whose pin I want to connect the vss and the declaration of the pin (apart from USE GROUND vs. USE POWER) is exactly the same, both are 'INOUT'. I would love some suggestions on where to look for the polarity and how to resolve the problem. 

     The nets are analog power supplies comming from pins, through a clamp. 

    • Post Points: 20
  • Fri, Nov 16 2012 1:31 AM

    • HSpeek
    • Not Ranked
    • Joined on Tue, Nov 22 2011
    • Posts 1
    • Points 5
    Re: globalNetConnect fails due to pin and net polarity Reply

    Hi,

     

    Not sure if you managed to solve this by now - but this error typically sigals that you are connecting a net of type power to a ground net, or vice versa.

    If the LEF of your cells is correct (has USE POWER and USE GROUND on the right pins), then you should look at how your vss_net is created. Is it specified as a ground net ? In Encounter 11.x you should have something like

    set init_pwr_net "vdd_net"
    set init_gnd_net "vss_net"

    or in Encounter 10.x

    set rda_Input(ui_pwrnet) {vdd_net}
    set rda_Input(ui_gndnet) {vss_net}

     in your TCL script.

     

    • Post Points: 5
Page 1 of 1 (2 items)
Sort Posts:
Started by mizzihood at 20 Aug 2012 06:07 AM. Topic has 1 replies.