Home > Community > Forums > Custom IC Design > nlambda must be defined or declared ERROR in ADEXL (again)

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 nlambda must be defined or declared ERROR in ADEXL (again) 

Last post Fri, Sep 13 2013 8:01 PM by yswang. 5 replies.
Started by vastsky 08 Jun 2012 01:27 AM. Topic has 5 replies and 1222 views
Page 1 of 1 (6 items)
Sort Posts:
  • Fri, Jun 8 2012 1:27 AM

    • vastsky
    • Not Ranked
    • Joined on Fri, Jun 8 2012
    • Posts 3
    • Points 60
    nlambda must be defined or declared ERROR in ADEXL (again) Reply
    Sorry to post the same issue as that in this thread: http://www.cadence.com/Community/forums/t/18826.aspx. I encounter exactly the same problem using ADE XL. But it seems like it hasn't been solved. And we are using IC614. Is there any solution now? Thank you very much!
    Filed under:
    • Post Points: 20
  • Fri, Jun 8 2012 1:45 AM

    Re: nlambda must be defined or declared ERROR in ADEXL (again) Reply

    I found a small number reports of this (always from Universities), and two of them were specifically something to do with a problem with the NCSU CDK 1.5.1 (the others were inconclusive or the students never responded).

    Maybe you're using this design kit? If so, I suggest you contact the providers since it seems to be that which is at fault - it doesn't appear to be a Cadence issue, but a customization issue.

    Regards,

    Andrew.

    • Post Points: 20
  • Fri, Jun 8 2012 2:28 AM

    • vastsky
    • Not Ranked
    • Joined on Fri, Jun 8 2012
    • Posts 3
    • Points 60
    Re: nlambda must be defined or declared ERROR in ADEXL (again) Reply

    I believe the problem is not related to the design kit. When I start a Virtuoso session without any customization and create a circuit with a voltage source and a resistor from analogLib, and attempt to run a single run in ADE XL , I get this "nlambda" must be defined error. I am using Ubuntu 11.04. 

    • Post Points: 20
  • Fri, Jun 8 2012 2:33 AM

    Re: nlambda must be defined or declared ERROR in ADEXL (again) Reply

    Do you have that design kit installed though? Just because you're not using it in your example does not mean that it won't have an influence... it may still have code being loaded via the .cdsinit file.

    You could repeat your test by doing:

    virtuoso -nocdsinit

    and then in the CIW entering:

    envSetVal("adexl.icrpStartup"  "binaryName" 'string "virtuoso -nocdsinit")

    before starting ADE XL.

    Regards,

    Andrew.

    • Post Points: 20
  • Fri, Jun 8 2012 4:28 AM

    • vastsky
    • Not Ranked
    • Joined on Fri, Jun 8 2012
    • Posts 3
    • Points 60
    Re: nlambda must be defined or declared ERROR in ADEXL (again) Reply
    Thank you very much! It is because of the customization issue after all.
    • Post Points: 20
  • Fri, Sep 13 2013 8:01 PM

    • yswang
    • Not Ranked
    • Joined on Fri, Feb 8 2013
    • Posts 1
    • Points 5
    Re: nlambda must be defined or declared ERROR in ADEXL (again) Reply

     I had the same problem with the NCSU FreePDK. The fix was to comment out some of the default settings.

     By keeping only the ones below, I was able to get everything to work.

    export PDK_DIR=<path to PDK dir>/45nPDK/FreePDK45
    export OSU_FREEPDK=${PDK_DIR}/osu_soc
    export PYTHONPATH=${PDK_DIR}/ncsu_basekit/techfile/cni:${PYTHONPATH}

    • Post Points: 5
Page 1 of 1 (6 items)
Sort Posts:
Started by vastsky at 08 Jun 2012 01:27 AM. Topic has 5 replies.