Home > Community > Forums > PCB SKILL > Calling script inside skill gives error E- Form field label not found

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Calling script inside skill gives error E- Form field label not found 

Last post Tue, May 29 2012 10:13 PM by pcbnagaraj. 4 replies.
Started by pcbnagaraj 27 May 2012 09:23 PM. Topic has 4 replies and 2535 views
Page 1 of 1 (5 items)
Sort Posts:
  • Sun, May 27 2012 9:23 PM

    • pcbnagaraj
    • Top 150 Contributor
    • Joined on Mon, Dec 5 2011
    • bangalore, Karnataka
    • Posts 55
    • Points 1,130
    Calling script inside skill gives error E- Form field label not found Reply
    Dear All,

    I am using the axlShell command to execute allegro command to dehilight all elements.

    when I run the skill from the SKILL prompt it works but when I run from Allegro command prompt it give me the below error

    E- Form field label not found

    Below is the command issues to allegro to dehilight all elements inside allegro.

    axlShell("dehilight ;setwindow form.find;FORM find all_on  ;setwindow form.mini;FORM mini dhlt_all  ;setwindow pcb;prepopup 0 0;done ")

    Thanks for your suggestions!!


    Thanks,

    Nagaraj.

     
    • Post Points: 35
  • Sun, May 27 2012 9:41 PM

    • Pawandeep
    • Top 75 Contributor
    • Joined on Sat, Oct 15 2011
    • Singapore, 00-SG
    • Posts 106
    • Points 1,690
    RE: Calling script inside skill gives error E- Form field label not found Reply
    Hi Nagaraj,

    Have you tried using axlClearSelSet() instead?

    Pawan
    • Post Points: 5
  • Sun, May 27 2012 9:51 PM

    • pcbnagaraj
    • Top 150 Contributor
    • Joined on Mon, Dec 5 2011
    • bangalore, Karnataka
    • Posts 55
    • Points 1,130
    RE: Calling script inside skill gives error E- Form field label not found Reply
    axlClearSelSet() will remove the dbids selected using Find filter.

    But I am trying to dehighlight all elements which are highlighted using ‘Assign Color’

    Thanks,

    Nagaraj.
    • Post Points: 5
  • Sun, May 27 2012 10:08 PM

    • Pawandeep
    • Top 75 Contributor
    • Joined on Sat, Oct 15 2011
    • Singapore, 00-SG
    • Posts 106
    • Points 1,690
    RE: Calling script inside skill gives error E- Form field label not found Reply
    Hi Nagaraj,

    What about axlDehighlightObject(List of highlighted dbids)?

    Pawan
    • Post Points: 5
  • Tue, May 29 2012 10:13 PM

    • pcbnagaraj
    • Top 150 Contributor
    • Joined on Mon, Dec 5 2011
    • bangalore, Karnataka
    • Posts 55
    • Points 1,130
    RE: Calling script inside skill gives error E- Form field label not found Reply
    It worked thanks.

    Thanks,

    Nagaraj.
    • Post Points: 5
Page 1 of 1 (5 items)
Sort Posts:
Started by pcbnagaraj at 27 May 2012 09:23 PM. Topic has 4 replies.