Home > Community > Forums > Functional Verification > System Verilog and AMS

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 System Verilog and AMS 

Last post Mon, Apr 2 2012 6:52 AM by tpylant. 1 replies.
Started by Anky 02 Apr 2012 02:41 AM. Topic has 1 replies and 2624 views
Page 1 of 1 (2 items)
Sort Posts:
  • Mon, Apr 2 2012 2:41 AM

    • Anky
    • Not Ranked
    • Joined on Mon, Apr 2 2012
    • Posts 2
    • Points 25
    System Verilog and AMS Reply

    Hi All,

    Which tool is supporting system verilog and ams both togather?

    I am using IUS 10.20-s106 and getting error as below:

    ncvlog: *F,AMSASV: The -ams and -sv options cannot be used together.

     Please help me out.

    Regards,

    Ankit

    • Post Points: 20
  • Mon, Apr 2 2012 6:52 AM

    • tpylant
    • Top 50 Contributor
    • Joined on Fri, Jul 11 2008
    • Austin, TX
    • Posts 135
    • Points 2,030
    RE: System Verilog and AMS Reply
    By using the “-sv” switch, you are turning on the SV compiler for ALL files. By using the “-ams” switch, you are turning on the AMS compiler for ALL files. Since AMS does not support SV, this is a conflict.

    The best way to use the “irun” command is to take advantage of automatic compiler selection by file name extension. You would name all your SV files with a “.sv” filename extension and all the Verilog AMS files with “.vams” extension. You would not need to specify the “-sv” or “-ams” switch and irun would pick the compiler based on the extension.

    If you don’t want to rename the filename extensions, you would need to run “irun –compile –ams” on just the Verilog AMS files and then run “irun –compile –sv” on just the SV files. Then you can run “irun –c” and “irun –R” to elaborate and simulate.

    Tim
    • Post Points: 5
Page 1 of 1 (2 items)
Sort Posts:
Started by Anky at 02 Apr 2012 02:41 AM. Topic has 1 replies.