Home > Community > Forums > PCB Design > SLPS Option error

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 SLPS Option error 

Last post Wed, Jul 3 2013 11:04 AM by taquionbcn. 7 replies.
Started by vin5488 21 Feb 2012 04:10 AM. Topic has 7 replies and 2606 views
Page 1 of 1 (8 items)
Sort Posts:
  • Tue, Feb 21 2012 4:10 AM

    • vin5488
    • Top 500 Contributor
    • Joined on Fri, Nov 18 2011
    • Posts 27
    • Points 465
    SLPS Option error Reply
    Hi, Whenever I open Matlab and setpath add all the slps library files and save it after doing this I get few sample circuits by doing 'slpslib' then if I simulate any circuit I can't able to simulate it gives error so is there an alternate to this currently I'm using 16.3 lib files for Matlab any help is appreciated. Regards, Vinay
    • Post Points: 35
  • Tue, Feb 21 2012 4:31 AM

    • alokt
    • Top 25 Contributor
    • Joined on Fri, Aug 22 2008
    • Noida, Uttar Pradesh
    • Posts 240
    • Points 3,450
    Re: SLPS Option error Reply

    What is the error message?

    • Post Points: 20
  • Tue, Feb 21 2012 4:44 AM

    • vin5488
    • Top 500 Contributor
    • Joined on Fri, Nov 18 2011
    • Posts 27
    • Points 465
    Re: SLPS Option error Reply
    I have attached the snapshot.
    • Post Points: 35
  • Thu, Aug 2 2012 7:07 AM

    • cucuna
    • Not Ranked
    • Joined on Thu, Aug 2 2012
    • Posts 1
    • Points 20
    Re: SLPS Option error Reply

    Hello?

    Do you solve the problem.

    I also meet the problem. I used 16.5 orcad and matlab 7.9 on win7

    Please reply.

     Thank you

    • Post Points: 20
  • Thu, Aug 2 2012 8:05 AM

    • oldmouldy
    • Top 10 Contributor
    • Joined on Tue, Jul 15 2008
    • Woking, Surrey
    • Posts 1,371
    • Points 23,350
    Re: SLPS Option error Reply

    If you are getting the "initialization" error, try the following:

    Close down the tools, if they are running,
    Configure the following environment variable:

    Use Control Panel>System>Advanced (or Advanced System Settings), then click on the Environment Variables button,
    Add a new variable to either the User, or System, Environment Variables as follows:

    Name: PSPICEINIPATH

    Value: %CDSROOT%\tools\pspice\pspice.ini

    And close the Environment editor.

    Try running the tools again.

    The tools cannot find the PSpice.ini settings file and get started with them.

    • Post Points: 5
  • Mon, Apr 15 2013 1:49 AM

    • TLIG
    • Not Ranked
    • Joined on Mon, Nov 26 2012
    • Sousse, Tunisia
    • Posts 7
    • Points 95
    Re: SLPS Option error Reply

    Hi,

    Can you send me the SLPS interface to use it and help you because i didn't find it in google 

    • Post Points: 20
  • Mon, Apr 15 2013 3:01 AM

    • oldmouldy
    • Top 10 Contributor
    • Joined on Tue, Jul 15 2008
    • Woking, Surrey
    • Posts 1,371
    • Points 23,350
    Re: SLPS Option error Reply
    SLPS is part of the Cadence SPB products, you need an installation of those products and a license to enable Capture / PSpice and the SLPS option to use them.
    • Post Points: 5
  • Wed, Jul 3 2013 11:04 AM

    • taquionbcn
    • Not Ranked
    • Joined on Wed, Jul 3 2013
    • Posts 1
    • Points 5
    Re: SLPS Option error Reply

    Hi there,

     I'm following a RC circuit tutorial of SLPSdemos, and I've created my own project in a separated folder C:/slpstest1 with all the basics: Captures cis project with the circuit (Vsrc,R,C)simulated with a transient working. Then I configure slps block in matlab, an simpler version 1 input, 1 output, and when I start simulink I get the error message:

     For S-function 'slpsblk', the number of defined parameters, 0, does not match the number of parameters on the dialog of 'test1r2012bw32/SLPS/S', 11. These two values must be identical.

     I compare all the simulink, model configuration parameters, preferences,....

    I usually use matlab for data analysis, but first time in simulink, and slps.

    it's wierd I'm unable to find any other dialog anywhere on matlab/simulink where to config this s- function parameters?

    if not, what I'm missing? 

    Thanks on advance,

    Guillermo

     

     

     

    • Post Points: 5
Page 1 of 1 (8 items)
Sort Posts:
Started by vin5488 at 21 Feb 2012 04:10 AM. Topic has 7 replies.