Home > Community > Forums > Digital Implementation > clock skew issue due to timing engines.

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 clock skew issue due to timing engines. 

Last post Mon, Jan 23 2012 11:18 AM by Vickey. 0 replies.
Started by Vickey 23 Jan 2012 11:18 AM. Topic has 0 replies and 1706 views
Page 1 of 1 (1 items)
Sort Posts:
  • Mon, Jan 23 2012 11:18 AM

    • Vickey
    • Not Ranked
    • Joined on Tue, Jan 3 2012
    • milpitas, CA
    • Posts 1
    • Points 5
    clock skew issue due to timing engines. Reply

    Hi All,

    I am new to EDI tool, right now I am seeing big clock skew on our designs with EDI flow (we are using foundation flow). After debugging this skew problem, I found that clock skew is due to miscorrelation between timing engines at different stages.

    For example on a routed database

    (a) IQRC extraction with "default" timing engine reports 230ps skew

    (b) IQRC extraction with "signal storm" timing engine reports 305ps skew

    But if I run "ckECO -postRoute -useSpecFileCellsOnly", tool starts skew optimization from 190ps skew. So looks like CTS uses a totally different timing engine and its hard to achieve good skew until ckECO sees correct skew. Please let me know if there are any tricks/workaround to run ckECO based on signoff timing engine or optimizing skew. 

     Thankyou in advance for any suggestions..

     

    Thanks

    VIkas

     

     

     

    Filed under:
    • Post Points: 5
Page 1 of 1 (1 items)
Sort Posts:
Started by Vickey at 23 Jan 2012 11:18 AM. Topic has 0 replies.