Home > Community > Forums > RF Design > Cannot get the Lorentzian plot in Pnoise simulation

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Cannot get the Lorentzian plot in Pnoise simulation 

Last post Wed, Jun 8 2011 5:00 PM by ycyang. 6 replies.
Started by ycyang 07 Jun 2011 06:57 PM. Topic has 6 replies and 2528 views
Page 1 of 1 (7 items)
Sort Posts:
  • Tue, Jun 7 2011 6:57 PM

    • ycyang
    • Not Ranked
    • Joined on Tue, Jun 7 2011
    • Posts 9
    • Points 150
    Cannot get the Lorentzian plot in Pnoise simulation Reply

    Hi,

    I am trying to run the PSS+Pnoise to get the linewidth of the VCO.
    I have set the Pnoise option "augmented=yes" for PSS+Pnoise oscillator simulations.
    Nevertheless, I cannot get the Lorentzian plot, the phase noise still goes up and becomes larger than 0 dBc at low frequencies.
    The logfile says:"Compute Floquet mode for autonomous ciruits... ...".
    It seems the simulator does not use frequency-aware PPV method.

    Is there anything wrong in my setting?
    By the way, the MMSIM version I use is 7.2ISR7

    Thanks

    Filed under:
    • Post Points: 20
  • Tue, Jun 7 2011 10:40 PM

    Re: Cannot get the Lorentzian plot in Pnoise simulation Reply

    The augmented parameter really has nothing to do with producing a Lorentzian plot. It is to enable an improvement in the PPV method to handle long time constants (often in the bias circuitry) which result in a hump in the phase noise transfer function. In fact from MMSIM72 ISR3 onwards augmented=yes by default in both shooting and HB pnoise.

    In earlier versions, when augmented=yes was turned on, it also enabled (for HB only) the calculation of the "line width" and computation of the Lorentzian (i.e. nonlinear) noise shape near the carrier. This was misleading because it was independent of the augmented algorithm, and also was doing it only for HB and not for shooting.

    What we did from MMSIM72 ISR4 onwards was to introduce a new parameter "lorentzian" on pnoise and hbnoise:

     43      lorentzian=cornerfreqonly
                              This option determines if the Lorentzian plot is used
                              in the oscillator noise analysis. Possible values are
                              no, cornerfreqonly or yes.

    The default is just to compute the corner frequency (i.e. the line width), and to get the Lorentzian shape curve you need to set it to "yes". 

    Regards,

    Andrew.

    • Post Points: 20
  • Tue, Jun 7 2011 11:32 PM

    • ycyang
    • Not Ranked
    • Joined on Tue, Jun 7 2011
    • Posts 9
    • Points 150
    Re: Cannot get the Lorentzian plot in Pnoise simulation Reply

    Hi Andrew,

    Thank you very much for your response, but I cannot find the parameter "lorentzian" on pnoise and hbnoise.
    Is it a check box or I have to type it in the additional parameter?
    Besides, I saw a message in the output log file saying "pnoise 'lorentzain' is not a valid parameter for an instance of 'pnoise'. Ignored"
    What does it mean?
    However, after I run the pnosie simulation, the simulation result still shows the line width.
    I am very confused why it can still compute the line width and if it is a correct result.

    Thanks

    Regards,

    ycyang

    • Post Points: 20
  • Wed, Jun 8 2011 3:25 AM

    Re: Cannot get the Lorentzian plot in Pnoise simulation Reply

    Hi Ycyang,

    Recent enough versions of the ADE environment would show lorentzian on the options form. In older versions you would just need to type:

    lorentzian=yes

    in the "Additional Parameters" field on the pnoise/hbnoise options form.

    Given the message you described had a typo in it, I don't know what exactly you tried - maybe if this doesn't work you can post both the analysis statements (cut and pasted, rather than transcribed) and the complete spectre.out file (as an attachment; go to the Options Tab when you reply to the post).

    Regards,

    Andrew.

    • Post Points: 20
  • Wed, Jun 8 2011 4:49 AM

    • ycyang
    • Not Ranked
    • Joined on Tue, Jun 7 2011
    • Posts 9
    • Points 150
    Re: Cannot get the Lorentzian plot in Pnoise simulation Reply

    Hi Andrew,

    Thanks again for your help.
    I did check the option tab but cannot find "Lorentzian", so I just type "lorentzian=yes" in the Addtional Parameters field.
    The attched file is the spectre.out file which still shows 'lorentzian' is not a valid parameter for an instance of 'pnoise'. Ignored"
    Even though, the simulated phase noise has a Lorentzian noise shape near the carrier (I do not know how to insert image yet and cannot post it). Thus I wonder if the result is correct or not.

    Regards,

    ycyang

    • Post Points: 20
  • Wed, Jun 8 2011 5:24 AM

    Re: Cannot get the Lorentzian plot in Pnoise simulation Reply

    Hi ycyang,

    Looking at the log file, I see you're using MMSIM 7.2.0.109 . That is the base version of MMSIM72 and is not ISR7 that you mentioned earlier. That is before the ISR4 version I mentioned earlier. Before we introduced the lorentzian parameter, when augmented was yes (which was not "yes" by default before ISR3, although the augmented algorithm was enabled always for HB), it also plotted with the Lorentzian shape. It should be correct.

    However, I would probably advise moving to a later version than the one you're using, because at the very least this linkage of the Lorentzian shape with the augmented switch is confusing, to say the least (which is why we sorted it out in ISR4).

    I'm a bit confused because initially you said you couldn't get the Lorentzian plot, and now you're saying that you are getting it - and this is nothing to do with the lorentzian parameter you've added, since you're using a version prior to that parameter being supported. I suspect your earlier run was done without augmented being set to yes?

    Regards,

    Andrew.

    • Post Points: 20
  • Wed, Jun 8 2011 5:00 PM

    • ycyang
    • Not Ranked
    • Joined on Tue, Jun 7 2011
    • Posts 9
    • Points 150
    Re: Cannot get the Lorentzian plot in Pnoise simulation Reply

    Hi Andrew

    I found I used wrong version of MMSIM after reading your reply. After switching to a later version, the warning message disappeared.
    As for the problem that I could not get the Loretzain plot in the beginning, I am sure that the option "augmented" was set to yes. I don't know why the Lorentzain didn't show. I will discuss this with our CAD engineer.
    Thank you very much for you assistance.

    Regards,

    ycyang

    • Post Points: 5
Page 1 of 1 (7 items)
Sort Posts:
Started by ycyang at 07 Jun 2011 06:57 PM. Topic has 6 replies.