Home > Community > Forums > Custom IC Design > Monte Carlo simulation under ADE XL

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Monte Carlo simulation under ADE XL 

Last post Wed, Feb 23 2011 2:56 AM by Quek. 3 replies.
Started by chihai2011 08 Feb 2011 09:13 AM. Topic has 3 replies and 2759 views
Page 1 of 1 (4 items)
Sort Posts:
  • Tue, Feb 8 2011 9:13 AM

    • chihai2011
    • Not Ranked
    • Joined on Tue, Feb 8 2011
    • Posts 1
    • Points 20
    Monte Carlo simulation under ADE XL Reply

     Hi, guys

     Revently when I was working on Monte Carlo simulation with ADE XL, there is an error happening all the time .

    \o *Error*   Error ID  = 5011
    \o *Error*   Error Msg = Simulator failed to complete the simulation.
    \o
    \o           Error found by spectre during hierarchy flattening.
    \o ERROR
    \o           (SFE-1997): "input.scs" 25: mc1: parameter `dut': A scalar
    \o           is expected as the value for parameter `dut'.

    It also says there is not statistical data generated.

    Could you please help me on this?  Thank you so much!!!!!

     

    Filed under:
    • Post Points: 20
  • Wed, Feb 23 2011 2:41 AM

    • Quek
    • Top 10 Contributor
    • Joined on Wed, Oct 14 2009
    • Singapore, 00-SG
    • Posts 1,083
    • Points 16,480
    Re: Monte Carlo simulation under ADE XL Reply

    Hi chihai2011

    Are you able to run a normal spectre simulation? Would you please enter the following in ciw and let us know the output?

    getShellEnvVar("CDS_NETLISTING_MODE")

    Please also provide the following information:
    linux>virtuoso -W
    linux>spectre -W

    Best regards
    Quek

    • Post Points: 20
  • Wed, Feb 23 2011 2:54 AM

    Re: Monte Carlo simulation under ADE XL Reply

    Hi Quek,

    That should be "CDS_Netlisting_Mode" (the case is wrong). Simpler to use the SKILL function:

    cdsGetNetlistMode()

    Anyway, I suspect the issue is due to a version of spectre being used which is too old. Originally the "dut" (Device Under Test" had to be a single instance, but that changed in MMSIM70 Update 1 (7.0.1.053). If using a spectre version before that, and specifying the Device Under Test in the Monte carlo options form in ADE XL, then I suspect you could get this problem.

    Regards,

    Andrew.

    • Post Points: 20
  • Wed, Feb 23 2011 2:56 AM

    • Quek
    • Top 10 Contributor
    • Joined on Wed, Oct 14 2009
    • Singapore, 00-SG
    • Posts 1,083
    • Points 16,480
    Re: Monte Carlo simulation under ADE XL Reply
    Thanks Andrew. : )
    • Post Points: 5
Page 1 of 1 (4 items)
Sort Posts:
Started by chihai2011 at 08 Feb 2011 09:13 AM. Topic has 3 replies.