Home > Community > Forums > PCB Design > PCB Editor - Tree view not available

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 PCB Editor - Tree view not available 

Last post Fri, May 17 2013 8:01 AM by sakeser. 8 replies.
Started by ChrisL2 17 Jan 2011 09:02 AM. Topic has 8 replies and 2669 views
Page 1 of 1 (9 items)
Sort Posts:
  • Mon, Jan 17 2011 9:02 AM

    • ChrisL2
    • Not Ranked
    • Joined on Fri, Jan 14 2011
    • Posts 6
    • Points 120
    PCB Editor - Tree view not available Reply

    I am very new to PCB Editor and I'm sure I will end up posting a fair amount of Forum questions.  The first is that I am trying to do a manual place of components in the PCB Editor, and my tree view doesn't seem to be appearing properly.  In all the examples I have seen, there are check boxes next to the reference designators.  My tree view shows all the components, but there appears to be no way to select them as there are no check boxes in my view.  If I highlight the refdes name and then click "Hide" to try to place the component, nothing happens.

     It is worth noting that I am using version 16.3 on Windows 7.  This has already produced a few bugs that needed correction.  I assume this is the same situation.  Any suggestions?

     

    • Post Points: 20
  • Mon, Jan 17 2011 9:18 AM

    • Rik Lee
    • Top 50 Contributor
    • Joined on Tue, Dec 2 2008
    • HOME, SC
    • Posts 166
    • Points 2,730
    Re: PCB Editor - Tree view not available Reply

    This should no longer be a problem using v16-3-85BB or later releases (Use Help >About to determine your specific version). If you are using an erlier release use the workarounds below.
    If you are using a later release than this and still encounter the issue I'd suggest contacting Cadence Customer Support.


    From

    http://www.cadence.com/Community/forums/p/16421/757222.aspx#757222

    "djhutchi"

    We have seen this issue on certain Windows 7 laptops…

    try opening Control Panel\All Control Panel Items\Display & change to a smaller size – the default 125% might be the issue

    Cadence Online Support Solution 11630192

    "Windows 7 offers a Large Scale (120 DPI) option. Tree controls don't work correctly at the higher DPI settings. To change to a lower resolution go to Control Panel Display Screen Resolution and select "Make Text and Other Items Larger or Smaller". Select "Smaller" to get 96DPI."

    • Post Points: 20
  • Mon, Jan 17 2011 9:40 AM

    • ChrisL2
    • Not Ranked
    • Joined on Fri, Jan 14 2011
    • Posts 6
    • Points 120
    Re: PCB Editor - Tree view not available Reply

    Thanks for the quick reply!  It looks like I'm running 16.3 p006 (v16-3-85F).  I changed the Windows Display to 100 from 125, and sure enough, the check boxes show up now.  The only interesting thing is that in the place window, the "Hide" button disappeared.  This isn't a big deal - I will just move the window off to the side while I'm placing.  It's interesting that it happened though.

     Thanks again!

    • Post Points: 20
  • Tue, Jan 18 2011 1:21 AM

    • steve
    • Top 10 Contributor
    • Joined on Fri, Jul 18 2008
    • Woking, Surrey
    • Posts 1,239
    • Points 20,180
    Re: PCB Editor - Tree view not available Reply

    The Hide button normally disappears when you are in Placement Application Mode. There are three, General, Etch and Placement. They are the three green icons in the left hand corner or you can access them from the RMB - Application Mode menu.

    • Post Points: 20
  • Tue, Jan 18 2011 2:19 PM

    • ChrisL2
    • Not Ranked
    • Joined on Fri, Jan 14 2011
    • Posts 6
    • Points 120
    Re: PCB Editor - Tree view not available Reply

    You're absolutely right.  Hide reappears in General and Etch modes.  Thanks for helping me out.

    • Post Points: 20
  • Wed, Apr 10 2013 9:59 AM

    • sakeser
    • Not Ranked
    • Joined on Wed, Mar 6 2013
    • Posts 4
    • Points 50
    Re: PCB Editor - Tree view not available Reply

     I have a similar problem to the OP. I am trying to place a mechanical symbol (mounting holes, which I have done before on this board and others) on a board where I have already placed and routedmy components.

     Unfortunately, when I do Place-> Manual... like I did before, I get the same message in the command "Select elements to place using tree view.", but I can't see it!

     I know the tree view its referring to, but I don't seem to be able to get that view to come up again, no matter what I do. Any suggestions?

    • Post Points: 20
  • Thu, Apr 11 2013 1:05 AM

    • steve
    • Top 10 Contributor
    • Joined on Fri, Jul 18 2008
    • Woking, Surrey
    • Posts 1,239
    • Points 20,180
    Re: PCB Editor - Tree view not available Reply

    Close Allegro, try locating your pcbenv folder (normally in %HOME%\pcbenv) and rename it to pcbenv_old. Then restart Allegro and see if that helps.

    • Post Points: 20
  • Thu, Apr 11 2013 7:26 AM

    • sakeser
    • Not Ranked
    • Joined on Wed, Mar 6 2013
    • Posts 4
    • Points 50
    Re: PCB Editor - Tree view not available Reply

    That did it, thanks a lot! 

     

    • Post Points: 5
  • Fri, May 17 2013 8:01 AM

    • sakeser
    • Not Ranked
    • Joined on Wed, Mar 6 2013
    • Posts 4
    • Points 50
    Re: PCB Editor - Tree view not available Reply

     I just noticed that by renaming the old pcbenv folder, Iost the autorouter menu. 

     Is anyone aware of what causes this and how I can recover my precious autorouter functionality?

    • Post Points: 5
Page 1 of 1 (9 items)
Sort Posts:
Started by ChrisL2 at 17 Jan 2011 09:02 AM. Topic has 8 replies.