Home > Community > Forums > PCB Design > Dynamic shape with solid fill does not plot solid black

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Dynamic shape with solid fill does not plot solid black 

Last post Tue, May 20 2014 11:27 AM by Mambiber. 8 replies.
Started by John Davies 16 Apr 2010 06:32 PM. Topic has 8 replies and 3250 views
Page 1 of 1 (9 items)
Sort Posts:
  • Fri, Apr 16 2010 6:32 PM

    • John Davies
    • Top 150 Contributor
    • Joined on Tue, Aug 12 2008
    • Glasgow, Strathclyde
    • Posts 45
    • Points 810
    Dynamic shape with solid fill does not plot solid black Reply

    We produce photomasks by changing the colors of the desired features to black and using the Plot command. This works well for most of the etch but not for dynamic shapes with solid fills, which print gray instead of black. Connect lines and cross-hatched fills print black but a solid fill does not. The gray is very dark and looks like black in Plot Preview on the screen but emerges distinctly gray from a laserprinter. The darkness varies between printers. Printing to pdf with Distiller gives a shape that looks black on screen but again becomes gray from a printer.

    Can anybody suggest how to make the fill genuinely black, please? I am using OrCAD 16.3 on Windows XP.

    Filed under: , ,
    • Post Points: 35
  • Sat, Apr 17 2010 4:05 AM

    • redwire
    • Top 10 Contributor
    • Joined on Thu, Jul 17 2008
    • Allen, TX
    • Posts 876
    • Points 13,500
    Re: Dynamic shape with solid fill does not plot solid black Reply

     Why aren't you using Gerber and processing the Gerber film instead?

    • Post Points: 20
  • Mon, Apr 19 2010 1:14 PM

    • John Davies
    • Top 150 Contributor
    • Joined on Tue, Aug 12 2008
    • Glasgow, Strathclyde
    • Posts 45
    • Points 810
    Re: Dynamic shape with solid fill does not plot solid black Reply
    Thanks for the suggestion. We have a "traditional" (i.e. old-fashioned) in-house process for producing PCBs and use the Plot command to produce a photomask directly. I work in a university and this procedure enables us to produce simple PCBs very quickly for students. You're correct, we could write Gerbers and print them instead but it requires several extra steps and hasn't been necessary until we found the problem with shapes.
    • Post Points: 35
  • Wed, Jun 23 2010 4:51 AM

    Re: Dynamic shape with solid fill does not plot solid black Reply

    Hello,

    The solid plot is possible from PCB Editor directly. You could have enabled OpenGL from main menu Setup->User Preferences->Display->Opengl the disabl_opengl value could be unchecked. Than could be checked value in display_nohilitefont  Setup->User Preferences->Display->Highlight. Last step is setting the number of lines spacing for shape fill Setup->User Preferences->Display->Shape_fill display_shapefill set value 0. It is not clear but might help.

    • Post Points: 35
  • Sun, Feb 20 2011 6:36 PM

    • carlitos
    • Not Ranked
    • Joined on Sun, Mar 8 2009
    • Posts 3
    • Points 45
    Re: Dynamic shape with solid fill does not plot solid black Reply

     Thanks a lot for this information.

    It works for me too.

    Regards.

    • Post Points: 5
  • Thu, Apr 18 2013 6:50 AM

    • LEAS
    • Not Ranked
    • Joined on Tue, Apr 9 2013
    • Saint Ismier, Isere
    • Posts 8
    • Points 130
    Re: Dynamic shape with solid fill does not plot solid black Reply

    Hello.

    I use PCB Editor 16.6 and I don't set the number of lines in value 0 in Setup->User Preferences->Display->Shape_fil , I only can enable or disable this parameter.


    Thanks for your help. 

    • Post Points: 5
  • Thu, Apr 18 2013 10:47 AM

    • BuddSw
    • Top 500 Contributor
    • Joined on Thu, May 12 2011
    • Posts 35
    • Points 500
    Re: Dynamic shape with solid fill does not plot solid black Reply

    This post will not answer your question.  However, I do want you to know you are not alone with oddball plotting problems. I have had so many different little things not work properly that I now will only create Gerbers and them plot them. My favorite failure is turning on the primary side etch, looks right in preview, prints properly. Then I turn off the primary side etch, turn on the silksceen layers, looks right in plot preview, the actual plot scales incorrectly and cuts off a lot of the silkscreen to the right. CAM350 is so worth the money for what I do.

    • Post Points: 20
  • Thu, Apr 25 2013 2:59 AM

    • LEAS
    • Not Ranked
    • Joined on Tue, Apr 9 2013
    • Saint Ismier, Isere
    • Posts 8
    • Points 130
    Re: Dynamic shape with solid fill does not plot solid black Reply
    Finally, I found a solution to print shape dynamic in black solid.
    I set the parameters of the shape dynamic with type Xhatch and Hori_Vert.
    Line Width=0.508 ( First and Second )
    Spacing=0.0508  ( First and Second )
    Border width=0.508
    Angle=0 (First) and Angle=90 (Second)
    • Post Points: 5
  • Tue, May 20 2014 11:27 AM

    • Mambiber
    • Not Ranked
    • Joined on Tue, May 20 2014
    • Posts 1
    • Points 5
    Re: Dynamic shape with solid fill does not plot solid black Reply

    I had the same problem and with the next change its running ok. 

     

    Go to the menu bar SETUP --> User Preferences --> Display --> Shape_fill.

    For the variable display_shapefill put 0 inside the VALUE field.

    Apply and OK.

     

      

    • Post Points: 5
Page 1 of 1 (9 items)
Sort Posts:
Started by John Davies at 16 Apr 2010 06:32 PM. Topic has 8 replies.