Home > Community > Forums > RF Design > Insufficient memory

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Insufficient memory 

Last post Wed, Apr 7 2010 2:22 PM by Andrew Beckett. 6 replies.
Started by Mohana 05 Apr 2010 11:01 PM. Topic has 6 replies and 8938 views
Page 1 of 1 (7 items)
Sort Posts:
  • Mon, Apr 5 2010 11:01 PM

    • Mohana
    • Not Ranked
    • Joined on Tue, Apr 6 2010
    • Posts 12
    • Points 195
    Insufficient memory Reply

    I am trying to do parametric analysis on inverter using the ocean script where in i will be collecting my data points in a .cvs file.

    But when ever i try the ocean script, after few iterations it always stops and gives me this error of insufficent memory. 

    I have pasted the error that i get.

     Fatal error found by spectre.
        FATAL: Failed to created rechecking thread!
        FATAL: Failed to start license heart beat!
        FATAL: Failed to created rechecking thread!
        FATAL: Failed to start license heart beat!
        FATAL: Failed to created rechecking thread!
        FATAL: Failed to start license heart beat!
    Internal error found in spectre.  Please run `getSpectreFiles' or send the
            netlist, the spectre log file, the behavioral model files, and any
            other information that can help identify the problem to
            support@cadence.com.
        FATAL (CMI-2010): Assertion failed in file `analyses.c' at line 1109.


    Mem Used: 4073.6 MB (Memory Exhausted)


    Fatal error found by spectre.
        FATAL (CMI-2002): Insufficient memory available, To reduce memory for rf
            analyses, please refer "spectre -h rfmemory"

     

    How to i increase the memory so that i can run the iterations to collect more data points.

     

    Please help me with this problem.

     

    Thanks

    Mohana

    • Post Points: 20
  • Mon, Apr 5 2010 11:25 PM

    • Tawna
    • Top 25 Contributor
    • Joined on Fri, Jul 11 2008
    • Snohomish, WA
    • Posts 208
    • Points 5,500
    Re: Insufficient memory Reply

     Hi Mohana,

     

    You didn't mention what version of spectre and IC software that you are using.  

    Try using 64 bit instead of 32 bit mode.

     

    Add this to the OCEAN script:

    envOption( 'userCmdLineOption "-64" )

     

    best regards,

    Tawna

    Best regards, Tawna Wilsey Staff Support AE, Global Customer Support Cadence Design Systems, Inc.
    • Post Points: 20
  • Tue, Apr 6 2010 12:05 AM

    • Mohana
    • Not Ranked
    • Joined on Tue, Apr 6 2010
    • Posts 12
    • Points 195
    Re: Insufficient memory Reply

    the spectre that i am using is MMSIN72 and ic 6.1.4

    and I am using 64 bit machine.

     

    I have put in the command mentioned by you n it worked. Thanks a lot.

     

    Could you please explain me what that command meant and why was i not able to do it before and why i am able to do it now.

     

    Thanks a lot for the help.

    Mohana

     

    • Post Points: 20
  • Tue, Apr 6 2010 1:53 AM

    • Tawna
    • Top 25 Contributor
    • Joined on Fri, Jul 11 2008
    • Snohomish, WA
    • Posts 208
    • Points 5,500
    Re: Insufficient memory Reply

     Hi Mohana,

     

    The command that I provided "turns on" 64 bit spectre.  By default, spectre simulates in 32 bit mode.

     

    For more information, you may want to look at the following Solution on Cadence OnLine Support 

    http://support.cadence.com/wps/mypoc/cos?uri=deeplinkmin:ViewSolution;solutionNumber=11176820

     

    best regards,

    Tawna 

    Best regards, Tawna Wilsey Staff Support AE, Global Customer Support Cadence Design Systems, Inc.
    • Post Points: 35
  • Tue, Apr 6 2010 2:41 AM

    • Mohana
    • Not Ranked
    • Joined on Tue, Apr 6 2010
    • Posts 12
    • Points 195
    Re: Insufficient memory Reply

     hi Tawna,

    I am unable to open the link that was sent by you. Could you please attach that file and email me.

    My email address is m.ashalathadubasi@my.unt.edu.

    Thank you very much for your help.

    Mohana
    • Post Points: 5
  • Tue, Apr 6 2010 2:42 AM

    • Mohana
    • Not Ranked
    • Joined on Tue, Apr 6 2010
    • Posts 12
    • Points 195
    Re: Insufficient memory Reply

     

     hi Tawna,

    I am unable to open the link that was sent by you. Could you please attach that file and email me.

    My email address is m.ashalathadubasi@my.unt.edu.

    Thank you very much for your help.

    Mohana
    • Post Points: 20
  • Wed, Apr 7 2010 2:22 PM

    Re: Insufficient memory Reply

    The solution doesn't tell you much more than the fact that you can use $CDS_AUTO_64BIT to enable 64 bit mode for various applications, and use -64 as a command line option. Searching for CDS_AUTO_64BIT in the documentation would tell you more.

    By running in 64 bit mode, it means that pointers are then 64 bit long, which allows greater memory access than with a 32 bit application.

    However, you might also want to look into what you're doing - why is the simulation taking so much memory. Is it an RF simulation? If so, have you set it up properly? Perhaps giving some info as to what analyses you're running in spectre (a good way to show this would be to post the bottom parts of your input.scs which show the analysis statements). Also, show the circuit inventory that you get in the log file, so we can see the size of the circuit.

    Regards,

    Andrew.

    • Post Points: 5
Page 1 of 1 (7 items)
Sort Posts:
Started by Mohana at 05 Apr 2010 11:01 PM. Topic has 6 replies.